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SCOPE 

Products Covered by this Manual 
This User Manual provides information on how to install, configure and use the C236xC 
Series of Teleterm M2 RTU’s. 
 
This manual covers the following product Models: 

Model Description 

Models without Ethernet Port 

C2360C-0 Teleterm M2 Series RTU’s 
C2360C-0-1 Teleterm M2 Series RTU’s with ISaGRAF 
C2360C-11-0 Teleterm M2 Series RTU’s with GSM port 
C2360C-11-1 Teleterm M2 Series RTU’s with GSM port and ISaGRAF 
C2360C-21-0 Teleterm M2 Series RTU’s with Conet/c port 
C2360C-21-1 Teleterm M2 Series RTU’s with Conet/c port and ISaGRAF 
C2360C-31-0 Teleterm M2 Series RTU’s with 2.4GHz Radio port 
C2360C-31-1 Teleterm M2 Series RTU’s with 2.4GHz Radio port and ISaGRAF 
C2360C-33-0 Teleterm M2 Series RTU’s with 868MHz Radio port 
C2360C-33-1 Teleterm M2 Series RTU’s with 868MHz Radio port and ISaGRAF 
C2360C-34-0 Teleterm M2 Series RTU’s with 900M 1W Radio port 
C2360C-34-1 Teleterm M2 Series RTU’s with 900M 1W Radio port and ISaGRAF 

Models with Ethernet Port 
C2361C-0 Teleterm M2 Series RTU’s 
C2361C-0-1 Teleterm M2 Series RTU’s with ISaGRAF 
C2361C-11-0 Teleterm M2 Series RTU’s with GSM port 
C2361C-11-1 Teleterm M2 Series RTU’s with GSM port and ISaGRAF 
C2361C-21-0 Teleterm M2 Series RTU’s with Conet/c port 
C2361C-21-1 Teleterm M2 Series RTU’s with Conet/c port and ISaGRAF 
C2361C-31-0 Teleterm M2 Series RTU’s with 2.4GHz Radio port 
C2361C-31-1 Teleterm M2 Series RTU’s with 2.4GHz Radio port and ISaGRAF 
C2361C-33-0 Teleterm M2 Series RTU’s with 868MHz Radio port 
C2361C-33-1 Teleterm M2 Series RTU’s with 868MHz Radio port and ISaGRAF 
C2361C-34-0 Teleterm M2 Series RTU’s with 900M 1W Radio port 
C2361C-34-1 Teleterm M2 Series RTU’s with 900M 1W Radio port and ISaGRAF 
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Manual Revision History 
 

Date Revision Comments 
15 July 2011 1 Initial Issue 
August 2011 2 Update with new models and various corrections 
September 2011 3 Conet Subnet Routing section added 
October 2011 4 Added section for Ethernet Port configuration and removed 

battery tab paragraph . 
November 2011 5 Added IsaGRAF quick start example. 

 
 
Software Copy Available 

This manual is available in Adobe Acrobat pdf format. 
The pdf file is named UMC236xCR05.pdf 
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1. GENERAL DESCRIPTION 

1.1 Overview 
The C236xC range of TELETERM M2 RTU’s is designed specifically for industrial telemetry 
and remote I/O applications, combining powerful industrial network communications 
features with ease of use. 
1.1.1 Communications 
The TELETERM M2 Series RTU is available with a wide range of communications network 
options to enable communication with a broad selection of devices and machines. 
All I/O and configuration data variables are automatically accessible through Data 
Interchange Registers in a single “Data Interchange Table”, allowing the implementation of 
Remote I/O systems “out of the box”. 
1.1.2 Programmable 
Conventional remote I/O systems can be implemented without the need for any software 
programming, but the inclusion of two separate programming facilities within the M2 
provides a powerful customisation capability. 
The M2 Series can be supplied with the powerful and versatile ISaGRAF IEC61131 
standard graphical programming environment. This allows PLC functionality to be easily 
added to the RTU by the user. 
 
1.1.3 Memory Card 
The SD Card Slot provides the ability to store readings on a removable SD Card for remote 
logging applications. The data written to the SD Card is under control of the User Program, 
allowing flexibility of file structure and contents. 
1.1.4 Versatile Configurable Inputs and Outputs 
A Teleterm M2 Series RTU provides the ideal low cost remote interface to your assets or 
processes to provide the control and information that you need to optimise your operations. 
The M2 RTU’s are all equipped with 12 direct Binary and Analogue Inputs and Outputs. 
Each I/O can be uniquely configured as an input or output; analogue or digital. 
1.1.5 Built-in Serial Port 
An RS232/485 serial port supporting a number of protocols including Modbus and Conet/s 
allowing signals from a variety of sources to be monitored and controlled via the M2 RTU 
communications network of choice. 
As a basic I/O outstation, the M2 RTU’s are easily configurable using the free Omniset 
configuration software. Using Omniset PRO, the M2 Series can also be configured remotely 
over the installed network. 
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Figure 1.1: Front View of the Teleterm C2361C-34 M2Re with internal Radio modem – one of the 
products in the Teleterm M2 Range 
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1.2 Product Feature Matrix 
The following table identifies the features available on each of the products in the range: 
 

Product 
Name 

Order 
Code Notes 12 I/O

10/100 
Ether-

net 

RS232/ 
RS485 
Port 

EGSM/ 
GPRS 
Port 

3G 
UMTS 
Port 

 

Isa-
GRAF

Conet 
Port 

2.4GHz 
FSHH 
Radio  
Port 

868MHz
FSHH 
Radio 
Port 

 900MHz
FSHH 
Radio 
Port 

1x 
RS232 

1x 
RS232/ 
RS485 

M2 C2360C-0             

M2 C2360C-0-1             

M2e C2361C-0             

M2e C2361C-0-1             

M2R1 C2360C-31-0             

M2R1 C2360C-31-1             

M2R1e C2361C-31-0             

M2R1e C2361C-31-1             

M2R3 C2360C-33-0             

M2R3 C2360C-33-1             

M2R3e C2361C-33-0             

M2R3e C2361C-33-1             

M2R4 C2360C-34-0             

M2R4 C2360C-34-1             

M2R4e C2361C-34-0             

M2R4e C2361C-34-1             

Table 1-1 – Product Feature Matrix 

NOTES: 
1. The M2G version is available in a number of options to conform to different GSM based 

networks. Please ensure that the correct unit is specified for your application. 
2. The EGSM/GPRS port is a quad band device operating on 900/1800/850/1900MHz. This 

is suitable for use on most countries’ GSM networks. Consult the factory for specific 
compatibility with your network. 

3. The 3G UMTS port is a tri band device operating on 850/1900/2100MHz. This interface is 
specifically approved for use on the Australian Telstra NextG network. 

4. The M2R version is available in a number radio band options to comply with different 
country regulations. Please ensure that the correct unit is specified for your application. 

5. 2.4GHz Band is suitable for use all countries. 
6. 920MHz Band is suitable for use in Australia and New Zealand only. 
7. 900MHz Band is suitable for use in USA, Canada and other related FCC regulated areas. 
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1.3 Feature Descriptions 

1.3.1 I/O Terminals 
The Teleterm M2 is equipped with 12 software configurable input/output points (IO 
points). Each IO point can be individually configured as digital or analogue, input or 
output selected from the options given in the following table: 
 

I/O 
Point 

Terminal 
No. 

Digital 
Input 

Analogue 
Input 

Digital 
Output 

Analogue 
Output 

1 5 Yes 0-30Vdc Yes - 
2 6 Yes 0-30Vdc Yes - 
3 7 Yes 0-5Vdc Yes - 
4 8 Yes 0-5Vdc Yes - 
5 9 Yes 0-5Vdc Yes - 
6 10 Yes 0-5Vdc Yes - 
7 11 Yes 0-5Vdc Yes - 
8 12 Yes 0-5Vdc Yes - 
9 13 Yes 0-5Vdc Yes - 

10 14 Yes 0-5Vdc Yes - 
11 15 Yes 0-30Vdc - 0/4-20mA 
12 16 Yes 0-30Vdc - 0/4-20mA 

(See the specifications section for electrical specifications of each IO point option) 

Table 1-2 – I/O Configuration Options 

 

1.3.2 Programming Port – S2 
The programming port is normally reserved for all programming functions in the unit. 
Although it is possible to reconfigure this port as an additional serial port, this option 
should be carefully considered, as it does make trouble shooting and field 
maintenance more difficult. 
When using this port as a serial port, the serial port settings can be changed to suit 
the application. This will make this port incompatible with the programming tools. The 
SD pushbutton can be used to switch between programming mode and user mode. 
 

1.3.3 RS232/RS485 Serial Port – S1 
The Teleterm M2 RTU is equipped with a user serial port, labelled PORT 1, on the 
front of the unit. This serial port can be used as a communications port to third party 
equipment. 
This serial port can be wired for RS232 or RS485 communications. 
In normal mode, the serial port can be configured for a number of protocol sets: 

a) Modbus protocol (Master or Slave device, ASCII or RTU protocol) is available 
on this port allowing easy connection to other third party products such as 
Alarm Annunciators, PLC’s DCS or SCADA systems. 

b) Conet/s protocol is available for integration into Conet networks and for 
programming the Teleterm M2. 
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c) User control which allows custom protocols to be implemented in the 
EziFORTH programming language in the M2 RTU. 

 

1.3.4 Ethernet Port 
A 10/100 Ethernet port is available on all C2361B models of the Teleterm M2. This 
port supports the following protocols: 

a) Modbus/TCP protocol (Master or Slave) is available on this port allowing easy 
connection to other third party products such as Alarm Annunciators, PLC’s 
DCS or SCADA systems. 

b) Conet/e protocol is available for integration into Conet networks and for remote 
programming the Teleterm M2. 

 

1.3.5 Network Port 
Each M2 RTU in the series can be equipped with additional networking ports. The 
type of network port is dependent upon the Model of M2 RTU. The following table 
gives an overview of the available network port options and their applications: 
 

Product Order 
Code 

Network 
Port Description 

M2 C236xC-0 None The standard Teleterm M2 is equipped with only a 
programming port, and an RS232/485 serial port 

M2G 
C236xC-11 
C236xC-12 

GSM 

The M2G is equipped with an internal GSM modem 
capable of communicating over standard GSM mobile 
phone networks using dial-up, SMS or GPRS data 
services. 
The M2G is ideally suited for communicating with 
remote assets over very large distances (even different 
countries). 
The -11 option unit is compatible with all GSM networks 
worldwide. 
The -12 option unit is compatible with the Telstra NextG 
network in Australia. 

M2C C236xC-21 Conet 

The M2C is equipped with a Conet network port. 
Conet is the world’s most rugged Industrial LAN, 
capable of running over existing plant cabling up to 10 
kilometres. Up to 126 nodes may be connected to a 
Conet network in a token passing peer-to-peer 
architecture. 
The M2C is ideally suited for local in-plant 
communications where the cost of laying special 
networking cable is considered uneconomical for the 
application, but where existing cabling (of any sort) is 
already in place. 
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M2R 

C236xC-31 
C236xC-33 
C236xC-34 

 

Radio 

The M2R is equipped with an internal FHSS digital 
radio transceiver operating in the licence free radio 
bands. 
FHSS stands for Frequency Hopping Spread Spectrum 
and is an advanced technique for implementing secure 
error-free radio communications in the presence of high 
interference. 
The M2R is ideally suited for communications in areas 
where cable connections are impossible, and distances 
are relatively short (between 0.5km and 10km 
dependent upon the model and antenna selected) 
(See the selection guide for choosing the model 
appropriate for your country of use.) 

M2S C236xC-41 

RS232 
+ 

RS232 
/485 

The M2S is equipped with two additional serial ports. 
Port 3 is an RS232/485 port with the same pin-out and 
functionality as Port 1 – the built in serial port. 
Port 4 is an RS232 port with full hand-shaking 
capabilities suitable for interfacing to external modems, 
or to any other equipment capable of supporting a 
RS232 connection. 
The M2S is ideally suited for interfacing to external 
modems or to other third party equipment using the 
RS232/RS485 standard. 

Table 1-3 – Network Selection and Applications 
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2. Installing the Teleterm M2 RTU 

2.1 Mounting the Teleterm M2 
The Teleterm M2 is designed to be clipped to one of the following mounting rails: 

Top Hat Section (DIN) Rail 35/7.5mm in accordance with EN 60715: 1981 

Top Hat Section (DIN) Rail 35/15mm in accordance with EN 60715: 1981 

G Section Rail 32mm in accordance with EN 60715: 1981 
 
 
 

45

89
,5

54,5
46,5155

109,5
Height including serial cable

5

7,5

 

Figure 2.1: Mechanical Mounting Dimensions for the Teleterm M2 

 
 
 

2.2 Connecting direct Inputs and Outputs 
The Teleterm M2 has a unique feature of allowing each I/O point to be software configured 
as analogue or digital, input or output, for the best possible utilisation of I/O in any 
application. 
 
Review your I/O requirements, and then make the optimum allocation of the I/O, taking into 
account the variations in specification of each I/O Point. 
See Table 1-2 – I/O Configuration Options. 
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2.2.1 Connecting Digital Inputs 
Digital Inputs must be connected in accordance with the following schematic: 

1
2
3
4

n

+V

0V

+-

9-30Vdc
Supply

IOP 1 - IOP 12  

Figure 2.2 - Digital Input Connections 

Digital Input Specifications: 
Parameter Condition Value 
LED Indication Input On Green LED On 
Absolute Maximum Input Voltage  30Vdc 
Minimum High Level Input Voltage  3Vdc 
Maximum Low Level Input Voltage  2Vdc 
Input Current Vin = 5V 0.7mA 
Input Current Vin = 10V 1.7mA 
Input Current Vin = 12V 2.2mA 
Input Current Vin = 24V 4.7mA 
Input Current Vin = 30V 6.0mA 

 
2.2.2 Connecting Digital Outputs 
Digital Outputs must be connected in accordance with the following schematic: 

1
2
3
4

n

+V

0V

+-

9-30Vdc
Supply

IOP 1 - IOP 10

+

-
+V

 

Figure 2.3 - Digital Output Connections 

UMC236xCR045.pdf 16 -© Omniflex 
 



Teleterm M2 Series RTU User Manual  

 

 

Digital Output Specifications: 
Parameter Condition Value 
LED Indication Output On Green LED On 
Maximum Continuous Output Current Output On 50mA 
Maximum Peak Output Current 10ms max 200mA 
Maximum current for ALL Digital Outputs Outputs ON 500mA 
Minimum High Level Output Voltage   +VPSU – 2.5V 

 
 
2.2.3 Connecting Analogue Inputs 
Analogue Inputs must be connected in accordance with the following schematic: 

1
2
3
4

n

+V

0V

+-

9-30Vdc
Supply

IOP 1 - IOP 12

+

-

0-5/30V

 

Figure 2.4 - Analogue Input Connections 

 
Analogue Input Specifications: 

I/O Points 1-2, 11 and 12 
Parameter Value 
LED Indication None 
Absolute Maximum Input Voltage 30Vdc 
Input Impedance Minimum >500kΩ 
Minimum Measurable Input Voltage 0V 
Maximum measurable Input Voltage 30V 
Resolution over 0-5.5V 6mV 
Resolution over 5.5-30V 30mV 
Accuracy over 0-5.5V 0.15% of reading + 6mV 
Accuracy over 5.5-30V 0.15% of reading + 30mV 
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I/O Points 3 to 10 
Parameter Value 
LED Indication None 
Absolute Maximum Input Voltage 30Vdc 
Input Impedance Minimum >1MΩ 
Minimum Measurable Input Voltage 0V 
Maximum measurable Input Voltage 5.5V 
Resolution 6mV (10 bits) 
Accuracy 0.15% of reading + 6mV 

 
 
2.2.4 Connecting Analogue Outputs 
Analogue Outputs must be connected in accordance with the following schematic: 

 

1
2
3
4

n

+V

0V

+-

9-30Vdc
Supply

IOP 11 - IOP 12

+

-

4-20mA

+V

 

Figure 2.5 - Analogue Output Connections 

 
Analogue Output Specifications: 

Parameter Value 
LED Indication None 
Maximum Output Voltage Drive +VPSU – 5.0V 
Minimum Controllable Output Current 0mA maximum 
Maximum Controllable Output Current 23mA minimum 
Output Resolution 25μA 
Output Accuracy 0.1% of reading + 25μA 

 

2.3 Connecting the Programming Port S2 
The programming port is normally reserved for the programming function, but can be used 
as an additional RS232 serial port if desired. 
When connecting the programming port to a standard PC compatible serial port (DB9), the 
Omniflex programming cable Part Number M1831A (supplied separately) can be used. 
If another cable is to be used, the following connections will apply: 
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Signal Name DB9F Pin No. FCC-68 Pin No. 
Rx Data from M2 2 4 
Tx Data to M2 3 1 
Ground Reference 5 2 

All other pins are reserved and must not be connected. 

Table 2.1: Pin allocation of connectors on M1831A programming cable 

2.4 Connecting Serial Port S1 
This serial port is capable of RS232, RS422 or RS485 communications (two-wire or four-
wire). The selection of either RS232 or RS422/RS485 is achieved by specific wiring of the 
serial port connector. No other settings need be changed to select between RS232 and 
RS422/485. 
 

Communication Standard Pin 
number RS232 RS485 

1 Do not connect Rx Data + (In) 
2 Rx Data (In) Rx Data – (In) 
3 Tx Data (Out) Do not connect 
4 Do not connect Tx Data+ (Out) 
5 Ground Ground 
6 Do not connect Vcc 
7 RTS (Out) Do not connect 
8 CTS (In) Do not connect 

1

3

4

5

6

7

8

9

2

 

9 Do not connect Tx Data – (Out) 

Table 2-2: Pin allocation of Port 1 serial port connector on Teleterm M2. 

 
NOTE: The RTS and CTS handshaking lines are available for applications that require them. 
It is not a requirement of the CPU to use handshaking. In most applications connecting the 
RTS and CTS handshaking lines is not necessary. 
 

2.5 Connecting the optional Ethernet Port (Models C2361C-xx-x only)  
The C2361B models provide a standard Untwisted Pair Ethernet interface utilising a RJ45 
connector suitable for direct connection to a 10/100 Ethernet system. 
This port must be configured with a fixed IP address suitable for use on your Ethernet 
network. 
Consult your network administrator/consultant for further details of the Ethernet connectivity 
and setup before powering up the Teleterm M2 on to your Ethernet network. 
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2.6 Connecting Network Ports 

2.6.1 Teleterm M2G (Models C236xC-11, -12) with internal GSM/3G modem 

2.6.1.1. Inserting the Network SIM Card 
The Teleterm M2G requires a SIM card (not supplied) to enable the unit to 
operate on the selected GSM mobile phone network. 
To insert the SIM card: 
1. Remove the top cover of the Teleterm M2 by undoing the two hex 

screws holding the top cover of the unit, using a 2.5mm hex key 
(supplied). The cover is connected to the unit by the internal antenna 
cable, so be careful not to place any strain on this cable while removing 
the cover or inserting the SIM card. 

 
 

2. Insert the SIM card into the SIM card holder you will see in the centre of 
the unit. Take special care that the SIM card is correctly seated in the 
connector, and that the SIM card holder is properly closed. Press firmly 
down and slide forward to close securely. 

 

 
 

 
3. Replace the top cover. 

 
 

2.6.1.2. Connecting the Antenna 
The supplied Antenna’s cable should be screwed into the Antenna socket. 
Do not over tighten. This connector should be only finger tight to avoid 
damage. 
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2.6.1.3. Positioning the Antenna 
The antenna should be placed away from the Teleterm M2G in a position 
that gives the best possibility of a good signal on the mobile phone network. 
Avoid proximity of the antenna to shielding materials such as metal 
enclosures. 
The signal strength of the chosen location can be easily checked by holding 
a mobile phone (connected to the same network) in the intended position of 
the antenna, and checking that the signal strength on the phone is good. 
 

CAUTION: The antenna emits RF energy on a continuous basis, and should 
be positioned away from sensitive instrumentation, and away from areas 
where close proximity to personnel on a regular basis would occur. A 
separation distance of in excess of 30cm is recommended. 

 

2.6.2 Teleterm M2C (Model C236xC-21-x) with Conet network port 
It is recommended that the Teleterm M2C be connected to the Conet network using 
the C6169 Conet Termination Board and interconnecting cable. This ensures the 
integrity of the Conet network during maintenance of the RTU, and provides additional 
surge suppression and protection to the Teleterm M2C. 
 
See the C6169 Datasheet with application notes for full Conet installation details. 
 

Pin number Description 
2 Signal + 
5 Cable screen (S) 
8 Signal - 

 

1

3

4

5

6

7

8

9

2

 
 

1, 3, 4, 6, 7 and 9 No connection 

Table 2-3: Pin allocation of Conet port connector on the Teleterm M2C 

 

2.6.3 Teleterm M2R (Model C236xC-3x-x) with Radio Network Port 

2.6.3.1. Connecting the Antenna 
The M2R RTU is equipped with an RPSMA antenna connector found on the 
top edge of Teleterm M2R RTU. 
The appropriate antenna suitable for the application must be selected and 
purchased separately. 
Screw the antenna’s cable into the Antenna socket. Do not over tighten. 
This connector should be only finger tight to avoid damage. 
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2.6.3.2. Positioning the Antenna 
The antenna should be placed away from the Teleterm M2R in a position 
that gives the best possibility of good reception. Avoid proximity of the 
antenna to shielding materials such as metal enclosures. 
The signal strength of the chosen location can be easily checked by using 
the Omniset configuration software. 
CAUTION: The antenna emits RF energy on a continuous basis, and should 
be positioned away from sensitive instrumentation, and away from areas 
where close proximity to personnel on a regular basis would occur. 
 

2.6.4 Teleterm M2S (Model C236xC-41) with two additional Serial Ports 
The M2S is equipped with two additional serial ports called PORT 3 and Port 4. 
Port 3 is capable of either RS232 or RS485 operation. Port 4 is RS232 only with full 
handshaking suitable for driving a modem or other external serial device. 
 
Port 3 is capable of RS232, RS422 or RS485 communications (two-wire or four-wire). 
The selection of either RS232 or RS422/RS485 is achieved by specific wiring of the 
serial port connector. No other settings need be changed to select between RS232 
and RS422/485. 
 

Communication Standard Pin 
number RS232 RS485 

1 Do not connect Rx Data + (In) 
2 Rx Data (In) Rx Data – (In) 
3 Tx Data (Out) Do not connect 
4 Do not connect Tx Data+ (Out) 
5 Ground Ground 
6 Do not connect Vcc 
7 RTS (Out) Do not connect 
8 CTS (In) Do not connect 

1

3

4

5

6

7

8

9

2

 

9 Do not connect Tx Data – (Out) 

Table 2-4: Pin allocation of Port 3 serial port connector on Teleterm M2S. 

NOTE: This port is not isolated, and the Signal Ground is connected internally to the 
M2S Power Supply 0 Volt connection. 
 
NOTE: The RTS and CTS handshaking lines are available for applications that require 
them. It is not a requirement of the CPU to use handshaking. In most applications 
connecting the RTS and CTS handshaking lines is not necessary. 
 
The pin-out of PORT 4 is given in the following table: 
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Pin 
number 

 
In/Out 

 
Name 

 
Description 

1 I CD Carrier Detect 
2 I RD Received Data 
3 O TD Transmitted Data 
4 O DTR Data Terminal Ready 
5 - SG Signal Ground 
6 I DSR Data Set Ready 
7 O RTS Request To Send 
8 I CTS Clear To Send 
9 I RI Ring Indicator 

Table 2-5: Pin allocation of Port 4 serial port connector on M2S. 

NOTE: This port is not isolated, and the Signal Ground is connected internally to the 
M2S Power Supply 0 Volt connection. 
 

2.7 Powering up the Teleterm M2 
Upon power up, the Teleterm M2 will take approximately a few seconds to initialise the 
system and connect to the network. The front panel LED’s will all light for a short period 
before switching to their operational state at which point the green OK LED will stay steady 
on. In the case where a User Program is loaded and running on the unit, then the green 
RUN LED will also turn on steady. 
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3. Configuring the Teleterm M2 

3.1 Overview 
The Teleterm M2 C236xC Series is configured using the ‘Omniset’ software utility version 
7.3 or above. 
Omniset is a Windows98/NT/2000/XP compatible software package designed to configure a 
wide range of Omniflex products, including the Teleterm Teleterm M2. 
Omniset is available in two versions: 
The standard Omniset software is on the CD supplied with the Teleterm M2 RTU. 
Omniset may also be downloaded for free from the Omniflex web site www.omniflex.com . 
Omniset allows the Teleterm M2 to be configured through the serial port on the front of the 
unit. 
The ISaGRAF Workbench software is used for more advanced programming of the C236xC 
Teleterm M2. 

3.2 Incompatibility with Previous Versions of Omniset 

3.2.1 Versions of Omniset prior to 7.3 
The Teleterm M2 is only compatible with Omniset or Omniset PRO Version 7.3 
onwards. If you have a previous version of Omniset installed on your computer, then 
you need to upgrade to the latest version. 
You can check which version of Omniset you have installed by opening Omniset and 
then selecting the “Help>About…” menu item. 

3.3 Installing Omniset from the CD supplied 
Omniset is Windows98/NT/2000/XP compatible, and requires access to an RS232 port on 
your Windows computer. 
If your computer does not have a serial port available for use with Omniset, then 
inexpensive USB-to-Serial Converter modules are readily available that can be used with 
Omniset. 
To install Omniset from the CD supplied, follow these steps: 

1. Insert the CD into the CD drive of your computer. The Omniset installation should 
start automatically. If it does not, then, using Windows Explorer, navigate on the CD 
drive to the ‘Omniset’ directory and double click the file ‘setup.exe’. 

2. Follow the prompts on the screen to complete the installation. 
3. Select the COM port that you wish to use with Omniset by selecting ‘COM Port’ on 

the Data menu. 
4. Omniset uses “templates” to customise its appearance to suit the product being 

configured. Omniset is supplied with a complete library of templates for all Omniflex 
products, including the Teleterm Teleterm M2. This library is frequently being 
updated with new products and enhancements. If your computer is connected to the 
Internet, you can easily check for and download the latest template library by 
selecting “Update Template Library from Web…” on the Omniset File menu. Follow 

http://www.omniflex.com/
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the prompts to update your template library to the latest version. If you installed 
Omniset from the CD supplied with your Teleterm M2, and you do not have access 
to the Internet then do not worry. You will already have the template necessary to 
configure the Teleterm Teleterm M2 (although it may not be the latest version 
available). 

3.4 Connecting Omniset to the Teleterm M2 for first time 
To setup the Teleterm M2 using Omniset, follow this procedure: 
 

• 

• 
• 

Plug the programming cable supplied into the Programming Port on the front of the 
Teleterm M2 (the RJ11 socket, marked S2) and plug the other end into a serial port on 
your computer. 

Ensure that the Omniset software utility is running on your computer. 

To set the correct communications port on Omniset, click Options->Port Settings and 
enter the COM port number being used and click OK: 

 
• 
• 

Once this is set, Omniset, click File->Connect. 

Select the ‘Teleterm’ Product Group if prompted, and press OK: 
 

 
 

If successfully connected, you should see the following screen in Omniset 

UMC236xCR045.pdf 25 -© Omniflex 
 



Teleterm M2 Series RTU User Manual  

 

 

 
 

Check that the Product Name is correct for the version of Teleterm M2 connected and that 
the Product/File Compatibility is ‘Yes’. Note that the Product Name must match the product 

you are connected to and may be different to what is indicated above. 

Make sure that the Sync button  is depressed, and that the Sync mode icon is 
present in the Status bar at the bottom of the Omniset window. This indicates that Omniset 
is in Sync mode, and that the data visible in Omniset is synchronised with the Teleterm M2 
connected. In this Sync mode, any changes that you make in Omniset will automatically be 
written to the Teleterm M2. If Sync mode is NOT enabled, then changes you make to the 
configuration will NOT be written automatically to the Teleterm M2. You can write these 
values manually to the Teleterm M2 by selecting “Write Current Group” or “Write All 
Groups” from the “Data” menu. 
 
You are now ready to view or change any of the parameters in the Teleterm M2. 

3.5 Overview of the Teleterm M2 Configuration Template 
The pane on the left of the Omniset window shows a list of Groups of Items to be viewed or 
changed, arranged in Folders. Select a Group in the group pane on the left, to see the 
contents of the individual Items for that Group in the item pane on the right. 
By selecting either a Group, or an Item, Help information will be displayed for that Group or 
Item in the Help pane below the Item pane at the bottom of the Omniset window. 
See the Omniset Help for a more detailed description of the operation of Omniset. 
 
There are two important Groups in the left group pane: 
The Real-Time Data Group contains the current status of all data items in the Teleterm M2. 
Select one of the Real-Time Data Groups to see the current data in the Teleterm M2. 
The Configuration Group contains all the Items that can be configured in a Teleterm M2. 
The value of an Item in the right hand pane can be changed in a number of ways: 

1. Double-click the Item or 
2. Right Click the Item and select “New Value…” from the options provided. 

Enter the new value in the dialogue box and then press Enter or the ‘OK’ button. 
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Once you have completed the configuration of your Teleterm M2, you should save your 
configuration to your hard drive, so you have a backup of the configuration. 
Remember that if your Omniset is not synchronised to your target Teleterm M2 when you 
make any changes in Omniset, these changes will not be written to the Teleterm M2 until 
you press the “Write” or “Write All” button. 

3.6 Quick Configuration 
This procedure is recommended to check the Teleterm M2 operation for the first time. This 
provides the minimum amount of configuration necessary to achieve a simple functional test. 
This will give you a good starting point for further customisation to suit your specific 
application. 

3.6.1 Set the Real-time Clock 
The Real Time Clock Data Group shows the current date and time in the Teleterm M2, 
the time and date of the last power down, and the time and date of the last power up. 
To set the real-time clock, write the current time and date to the relevant Data Items in 
this Data Group. The clock will run immediately from this new time when it is written to 
the Teleterm M2. To change a data item, double the Item, or right click and select 
“New Value…”. 

 

 
 
Note that it is not necessary to set the Power Down and Power Up times, these will be 
set automatically by the unit once the time has been set and power cycled to the unit. 

3.6.2 Set the I/O Points to the type required 
The default setting as shipped from the factory is with all I/O points set as disabled. 
Each I/O Point can be set according to your requirements by selecting the I/O Points 
Group and then double-clicking each I/O Point in turn.  
This group gives a summary of each Input setting.  
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For detailed configuration of each Input to suite your application, select the actual I/O 
Point in the left Group pane. 
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3.7 Configuring the Serial Port S1 
The serial port (S1) on the Teleterm M2 comes equipped with four protocol options: 

1. Modbus Master (ASCII and RTU) 
2. Modbus Slave (ASCII and RTU) 
3. Conet/s protocol. 
4. User Protocol (Requires an installed user program to access the serial port) 
 

The required protocol including any address selection is made in the 
Configuration>Communications>Port Setup” Group. 

 

 
 

3.8 Configuring the Conet/c Network Port (available on the Teleterm M2C C236xC-21-
x only.) 
The Conet/c Port selection switch is located on the top edge of the M2 RTU along side the 
Port 2 Conet Network connector. Use this switch to configure the Node address of the RTU 
on the Conet network and the desired CONET baud-rate (Normal or Slow). 
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81 2 3 4 5 6 7
ON

81 2 3 4 5 6 7
ON

Communications Protocol Conet Address switch setting 
 
Conet (Normal mode): 
Baud rate: 62,500 baud 

 
Switches 1-7: Conet ID 
(Set in binary  
Switch 1 = LSB 
Switch 7 = MSB) 
Switch 8: Baud Rate 
Switch 8 OFF = 62.5 kBaud 
[Switch shown set to Address 2, Normal baud rate] 

 
Conet (Slow mode): 
Baud rate: 7,800 baud 

 
Switches 1-7: Conet ID 
Switch 8: Baud  
Switch 8 ON = 7.8 kBaud 
[Switch shown set to Address 2, Slow baud rate] 

Table 3-1: Conet Port Address switch settings on the M2C RTU) 

Each node on the Conet/c network should be allocated a unique address in sequence, 
starting at 1. While a Conet/c network will operate reliably with missing node addresses, 
best performance of the network will be achieved with all operating nodes having 
consecutive addresses. 
All Conet nodes in a network must be set to the same baud rate. 
 
Please refer to the Conet Installation Guide and Conet Protocol Datasheet for more 
information on the CONET network. 

3.9 Configuring the Ethernet Port (Teleterm M2e C2361C range only) 
The Ethernet port of the C2361C M2e Teleterm range supports both Modbus/TCP (Master 
and Slave) as well as Conet/e (for both TCP and UDP). Conet/e is a proprietary protocol 
from Omniflex. 
 
Modbus/TCP, being an open standard protocol, allows M2e units to be easily connected to 
third party devices or SCADA systems easily. 
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To setup the Ethernet port for operation, either for Modbus/TCP or Conet/e some Internet 
Protocol settings are required. These settings need to be supplied by your network 
administrator if you are unfamiliar with what these settings should be: 
 
Internet Protocol Settings: 
IP Address: - This is the general Internet Protocol address given to the unit. It must be a 
unique address on the Local Area Network (LAN) that the M2e is part of. The default setting 
is 192.168.0.100. 
 
IP Subnet Mask: The subnet mask for the (LAN) is configured here. This is the same for all 
network devices on the LAN. 
 
IP Gateway Address: In the event the M2e is part of a Wide Area Network (WAN) and is to 
be accessed from a device on a different LAN, then the IP address of the IP Gateway, that 
connects to the WAN must be configured here. 
 
Primary and Seconday DNS Servers: The M2e supports DNS lookup in certain applications 
where the M2e is deployed for access over the Internet. In this case the DNS server 
addresses must be configured to allow the use of Domain Names. The default settings of 
“208.67.222.222” and “8.8.8.8” are usually adequate and don’t require to be changed. 
 
Conet/e Protocol Settings: 
Conet/e TCP/UDP Port Number: This is the IP port number used by Conet/e as a default 
(i.e. 1300). This does not normally require to be changed. In the event that this IP Port is 
being used by other devices on the network, then it can be changed to another number in 
the unused block of IP Port Numbers i.e. 49152-65535. Note that all communicating units 
must use the same IP Port number. 
 
Port Unit ID: Each node on the Conet/e network also has a Unit ID over and above the IP 
address. This is necessary to support Conet Subnet Routing and must be set even if Conet 
Subnet Routing is not to be used. 
 
Modbus/TCP Protocol Settings: 
Modbus TCP Port Number: This is the IP port number used by Modbus TCP as per the 
Modbus TCP standard (i.e. 502). This does not normally require to be changed. In the event 
that this IP Port is being used by other devices on the network, then it can be changed to 
another number in the unused block of IP Port Numbers i.e. 49152-65535. Note that all 
communicating units must use the same IP Port number. 
 
Slave Address: Each node acting as a Modbus/TCP Slave on the network must be 
configured with a Slave Address over and above the IP address. This is necessary to 
support Conet Subnet Routing and must be set even if Conet Subnet Routing is not to be 
used. 
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3.10 Configuring the Radio Network Port (Teleterm M2R C236xC-34-x only.) 
M2R units use the Conet/r Protocol which is a full peer-to-peer radio network that allows the 
system designer to take advantage of flexible network topologies.  
The following parameters need to be configured in every node in the Conet/r network. 
These parameters can be found in the Omniset “Configuration>Communications> 
Port Setup” group. Look for the “Radio Network Port Settings” title to locate the specific 
Radio port settings. 

 
 
3.10.1 Configuring the Radio Network Node Address 

Each M2R connected to the radio network is considered a "Node" on the network. 
Each node must have a unique address. Set the address for each node uniquely in 
this item. 
Conet/r Protocol makes use of a powerful networking feature known as “Conet Subnet 
Routing” which is a networking architecture that allows an entire intranet of networks 
to interconnect and communicate. It also integrates radio repeating requirements. 
The network is therefore segmented into smaller localised networks called subnets.  
Up to 30 Subnets can be supported with up to 999 nodes per subnet. 
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The subnet in which a node exists is implied in the Node address of the unit by 
multiplying the subnet by 1000 and adding it to the Node number. Thus a node 
identified as Node 1 in subnet 1 will have a Node address of 1001. 
It is recommended practice, that for simple networks of a single subnet, that a subnet 
of 1 be used so radio nodes can be addressed as Node 1001, 1002, 1003 etc…  
Should additional subnet be required for repeating purposes or perhaps access from a 
SCADA system, then the application note: “Conet Subnet Routing” must be referred to 
for more details on how to implement such a system. 
If the node address is set to 0, then the radio will not transmit data on to the network, 
and will be unable to respond to requests from the network. 
 

3.10.2 Configuring the Inactivity Protection Timer 
This timer is used to reset the radio channel when an unacceptable length of time has 
elapsed without radio communications. In unusual network conditions it is possible for 
the radio network to enter a “deadlock” condition, where radio communications is 
prevented. This protection timer is used to prevent this extreme condition from 
causing permanent loss of communications. 
Set this timer to longer than you expect the network to ever be quiet. If this timer times 
out without network activity, then the M2 will assume that a deadlock condition has 
occurred, and will reset the radio channel to allow communications to resume. 
 

3.10.3 Configuring the Hopping Sequence Number 
The Conet/r network uses a Frequency Hopping Spread Spectrum (FHSS) to improve 
noise immunity and to allow multiple networks to exist within range of each other. 
FHSS is a technique where the transmitting node transmits for short time on one 
frequency and then hops to another frequency to continue transmission, and so on 
through a range of frequencies in a particular order. The frequencies are used in a 
predefined pseudo-random sequence that both the transmitter and receiver know. 
Receiving nodes listen in order on each of these frequencies to receive the entire 
message. 
Because the system transmits on a number of frequencies, the communication is 
more reliable and resistant to interference than a a system operating on a single 
frequency. 
By varying the hopping sequence, different radio networks can coexist within the 
same geographic area. 
The M2R can be set with one of 7 Hopping Sequences (0-6). All nodes on a single 
network must have the same Hopping Sequence Number. 
 
Note that this applies to the C236xC-31 and C236xC-34 Models only. The C236xC-33 
model (for 868MHz systems) does not support multi-channel hopping sequences. 
 

3.11 Other Configuration Settings 
There are a number of other settings that can be made in Omniset to fully configure your 
Teleterm M2. The settings for your particular M2 RTU will vary dependent upon the model. 
There is an Omniset Template customised for each version of M2 RTU.  
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Browse through all of the Configuration Groups in Omniset. The Help pane in Omniset will 
explain each of these additional settings. 
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4. The Data Interchange Table explained 

4.1 DIT Table Layout 
All data exchange with the M2 RTU is done via the “Data Interchange Table” (DIT). Any 
exchange of data between functions in the M2 RTU and/or with the outside world takes 
place through this DIT. 
The Data Interchange Table (DIT) in the M2 RTU is used for reading and writing all 
configuration and dynamic data in the M2. 
The DIT is an array of 16 bit registers accessible from any function or communications port 
in the M2 RTU – including Modbus. Even the Omniset configuration template interfaces to 
the M2 RTU through the DIT. 
Each data register in the DIT has a data address on the range 0 to 65535. Not all 
addresses are accessible.  
Any of these registers may be accessed through any of the network ports, allowing remote 
I/O systems to be implemented “out-of-the-box” without any programming required. 
I/O status is also accessed through this interface and the unit automatically updates I/O 
status as it is read and written to and from the DIT. 
In addition to I/O status and configuration requirements, the DIT is also the place where 
User will place user specific data such as Modbus Query status data or User Program data. 
The DIT has two main sections, namely a Dynamic Data area and a Static Data area. 
The Dynamic Data area is dedicated to status indication that is refreshed on an ongoing 
basis while the unit is powered. No values are retained during power fail. 
The Static Data area is a non-volatile section of the DIT that retains settings during power 
fail. This area is where the M2 RTU configuration is stored. 
 
The DIT has a predefined layout that includes these user areas that is summarised as 
follows: 
 
Data Interchange Table (DIT) Layout for the Teleterm M2 C236xC Series 

Dynamic DIT:  from 0 to 29999 – Volatile memory area 
DIT Register Range Description 
0 – 499 500 Status registers reserved for use by the M2 firmware. This 

area includes status indicators such as Program status, 
network status, I/O etc… 

500 -19999 19500 Volatile User Scratch pad. This is an open area of registers 
available for application requirements whether by ISaGRAF 
program, Modbus query data or Subscription information.  
Values are reset to zero on power cycle. 

20000 – 29999 10000 Not available 

Static  DIT: from 0 to 59999 – Non-Volatile memory area 
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DIT Register Range Description 
30000 - 39999 10000 Configuration registers reserved for the M2 firmware. 

Configuration of all the built-in functions of the unit is stored 
here. 

40000 – 46999 7000 Non-volatile User Scratch pad. Available to the user for non-
volatile storage of user specific data. Note that frequently 
changing values should not be stored here as this may 
result in non-volatile memory failure. 

47000 – 59999 13000 Not available 
 
For specific details, please refer to the Omniset template pertaining to the specific model 
being used. 
 

4.2 DIT I/O Map 
All inputs and outputs are read/written through registers in the DIT. The following table 
gives a summary of the more popularly used registers for I/O access. The current template 
file for your version of firmware should be used as a reference for any other register 
locations required. 
 
DIT Register Range Description 
250 1 Digital Inputs 

Packed as 1 bit per input – Bits 0-11 for Inputs 1 – 12. 
Bits 12 -15 will always be 0. 

260 1 Digital Outputs 
Packed as 1 bit per output – Bits 0-9 for outputs 1 – 10. 
Bits 12 -15 will be ignored 

270 1 Analogue Input 1 voltage (in millivolts) 
271 1 Analogue Input 2 voltage (in millivolts) 
272 1 Analogue Input 3 voltage (in millivolts) 
273 1 Analogue Input 4 voltage (in millivolts) 
274 1 Analogue Input 5 voltage (in millivolts) 
275 1 Analogue Input 6 voltage (in millivolts) 
276 1 Analogue Input 7 voltage (in millivolts) 
277 1 Analogue Input 8 voltage (in millivolts) 
278 1 Analogue Input 9 voltage (in millivolts) 
279 1 Analogue Input 10 voltage (in millivolts) 
280 1 Analogue Input 11 voltage (in millivolts) 
281 1 Analogue Input 12 voltage (in millivolts) 
340-1 2 Analogue Output 11 Current (depends on user scaling) 
342-3 2 Analogue Output 12 Current (depends on use scaling) 
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5. Modbus and the Teleterm M2 

5.1 Overview 
A unique and powerful feature of the Teleterm M2 is its ability to read data from any device 
equipped with a Modbus port. 
Examples of equipment that can be interrogated for data are instruments such as PLC’s, 
SCADA packages, on-line analysers, flow meters etc. 
Modbus is the most popular standard for the exchange of data between industrial 
instrumentation today. Modbus is a well established reliable standard that is easy to use. 
Modbus is a serial multi-drop Master/Slave protocol. This means that you can connect one 
or more Slave devices to a Master device over a serial communication link. If only one 
Slave device is being used, and the distance between the Master and Slave devices is less 
than 15m, then the simpler more popular RS232 electrical standard can be used. If two or 
more Slaves are to be connected to the Master Device, or the distance between the devices 
is greater than 15m, then the RS485 electrical standard must be used. 
There are no internal settings in the Teleterm M2 for selecting RS232 or RS485. All that is 
required is to wire the appropriate pins of the serial connector for the chosen standard. 

5.2 Modbus Slave 

5.2.1 Selecting the Slave Protocol Details 
Setting up Modbus Slave protocol requires configuration of the serial port in the 
“Configuration>Communications>Port Setup” group, including ASCII and RTU mode, 
Baud Rate, Parity, number of Data bits and Stop bits etc. 
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5.2.2 Modbus Data Register Mapping 
The Modus protocol in the Teleterm M2 supports the reading and writing of a number 
of different types of data: Digital Status Inputs, Coil Outputs, Input Registers and 
Holding Registers. 
These Modbus Data types are mapped to specific areas of the Teleterm M2’s Scratch 
Pad Registers. It is not normally necessary to change this layout, but you may do so 
for specific applications. The default settings are as follows: 
 

 
 
The most efficient data type to use is Holding Register Read (Modbus Function 3) and 
Holding Register Write (Modbus Function 16). 

5.3 Modbus Master 

5.3.1 Selecting the Master Protocol Details 
Setting up Modbus Master protocol requires configuration of the serial port in the 
“Configuration/Communications/Serial Port” group, including ASCII and RTU mode, 
Baud Rate, Parity, number of Data bits and Stop bits etc. 
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5.3.2 Modbus Master General Settings 
In order to control the manner in which Modbus queries are executed, it is necessary 
to configure some general settings. 

 
 
Query Response Timeout: This is the time period the Modbus Master will wait to 
receive a response to a Modbus Query just sent. If the reply is not received within the 
timeout period then the query is considered failed and the query will be sent again for 
as many retries are configured or until a reply is received. 
 
Interquery Delay: This delay is inserted in between each query from the Modbus 
Master regardless of whether a query is due to run or not. Its purpose is to regulate 
the flow of packets to multiple devices on the multidropped network. This Delay 
override the cyclic timer settings of a query such that if a query is configured for 1 
second poll rate (i.e. Cyclic timer is set to 1 second) but the interquery delay is set to 3 
seconds, then the fastest that query will poll the slave unit is one poll every 3 seconds. 
 
Suspend Timeout: In the event that a query to a Modbus Slave unit fails (i.e. no reply 
after the retries have been exhausted) the Modbus Master will suspend that query and 
all other queries configured for that Modbus Slave for the duration of the suspend 
timeout. This allows all other queries to other operational units to resume without 
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interruption while a unit is offline. The suspension is lifted after the timeout to see if 
that unit has come back online. 
 
Number of Retries: This configures how many times the Modbus Master will retry the 
transmission of a Modbus query if the first attempts are unsuccessful. Once all the 
retries have been exhausted, with no successful reply, the query is suspended from 
the polling sequence for the duration of the suspend timeout. 
 

5.3.3 Query Blocks 
In order to use the Modbus Master facility in the Teleterm M2 to get data from another 
Modbus Slave, “Query Blocks” have to be configured that tell the Teleterm M2 where 
to get the data from which Slave, where in the Teleterm M2 to place the data, and 
which Modbus Function to use to acquire the data. 
C236xC M2s with Firmware Version 4.xx support up to 64 Query Blocks. 
C236xC M2s with Firmware Version 5.xx support up to 128 Query Blocks.  
 

 
 
In the example shown above for Query 1, each data item has the following meaning: 
Port: Select the communications port that Modbus Master will communicate with. 
Type: Queries can be configured to run in either Cyclic or One-shot mode.  
Cyclic means that the query will repeat on a timed cycle as set by the Cyclic Period. 
One-shot queries are queries that are run on manually trigger, single or “one-shot” 
basis. One-shot queries are triggered using the Modbus Master Query Trigger group 
as shown below. 

UMC236xCR045.pdf 40 -© Omniflex 
 



Teleterm M2 Series RTU User Manual  

 

 

 
 
Slave Unit ID: This is the Modbus Address of the Slave device to be polled. 
Modbus Function Number: There are number of types of messages called 
“functions” that the Modbus protocol supports. Function 3 for reading general purpose 
Holding Registers is the most commonly used for this purpose because it is the most 
efficient for reading larger amounts of data. 
 

Function Description 
1 Read Coil Status 
2 Read Input Status 
3 Read Multiple Holding Registers 
4 Read Multiple Input Registers 
5 Write Single Coil 
6 Write Single Holding Register 

15 Write Multiple Coils 
16 Write Multiple Holding Registers 

 
 
Slave Start Address: This is the address of the first Holding Register to be read from 
the Slave device, 
Range: This is the number of Holding registers to be read from the Slave device. 
Local DIT Start: This is the starting address of the local Register in the Teleterm M2 
where the data will be written. The registers in the range 350 to 399 are reserved for 
this purpose in the Teleterm M2. 
 
Once Queries are configured, they must then be enabled. This applies to both cyclic 
and one-shot queries. The Query Summany group is a convenient group to enable 
and disable queries: 
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6. The Subscription Service Explained 

6.1 Introduction to Subscriptions 
Central to many applications involving communications across networks is the need to 
replicate data between nodes on the network. 
Examples include a SCADA system acquiring data from remote telemetry units in the field; 
or a point-to-point telemetry application, where inputs are transmitted from one location to 
outputs at another location. 
In all these cases, the traditional method is for a controlling master node to poll the slave 
nodes regularly for data in case something has changed. This crude method is an inefficient 
use of the limited network bandwidth, and is inherently slow in typical and worst case 
update times. It also limits the number of master nodes in the system to one, and makes the 
system update times very slow where many outstations are involved. 
The Teleterm M2 provides a far superior mechanism to accomplish this commonly used 
function through its Subscription Service. The subscription Service runs on all Conet/c 
(industrial LAN), Conet/r (FHSS radio) and Conet/e (Ethernet) networks, and is supported 
on all Omniflex products supporting these network types. This allows the M2 RTU to be 
used as remote I/O for other Omniflex equipment such as the Maxiflex Process Automation 
Controller Suite of products, or to be interconnected in a unified data environment. 

6.2 How Subscriptions Work 
The Subscription Service operates as follows: 
The node requiring the data (the receiver) sets up a subscription with the node that has the 
data (the sender), very much like you would subscribe to a magazine through your 
newsagent. You establish a magazine subscription by telling the newsagent which 
magazine you want, your home address, and how often you want it, and then the 
newsagent takes the responsibility to send you the magazine whenever a new issue 
becomes available. 
 

 

Subscriber Newsagent

Request subscription

August issue

September issue

October issue

etc...   

Figure 6.1 The Magazine Subscription Analogy. 

 
In the same way, the M2’s Subscription Service allows the M2 (acting as a node on the 
network) to subscribe to a range of DIT registers on a remote node. 
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The remote node will then send the data at an agreed time interval, plus, if required, when 
the data changes state. The receiving node expects these regular updates, and will flag an 
error if the subscribed data is interrupted for any reason. 
 

6.3 Setting up subscriptions 
Just like the magazine subscription, the receiving M2 is responsible for setting up and 
maintaining subscriptions with other nodes to replicate data across the network. The 
advantages of using subscriptions over regular polling mechanisms are as follows: 

1. Only one message is required on the network for a data update as opposed to two in a 
Request/Reply polling method. This reduces network overhead allowing more data 
throughput on the network. 

2. The regular data updates can be much slower than the response time required for the 
system by using change-of-state detection. The Source node will send data 
immediately there is a change of state, providing the optimum system response, 
without the need to have a fast regular update time. This reduces network overhead 
allowing more/faster data throughput on the network when something does change. 

3. On peer-to-peer networks multiple subscriptions can be configured between nodes in 
different directions, each of which would operate independently of any other. This 
provides far more flexibility than typical Poll/Response Master/Slave methods. 

 
 
 

Data
Sink

Data
Source

Subscription
Setup

Registers

Setup Message

Regular Data updates

The Receiving
Node

The Sending
Node  

 
 
 
The node acting as a data “producer” (the sending node) requires no user configuration to 
participate in a subscription contract with another node. The node acting as data 
“consumer” (the receiving node) is configured by the user for the required data. The 
“consumer” node then automatically manages the subscription including sending the 
requests to the data source, and managing errors in the process. 
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The following table shows the information required to configure a subscription:  
 

ITEM DESCRIPTION VALID RANGE 

Change-of-State Required This sets whether the subscription data block will be sent 
when any data in the block changes. 

Yes/No 

Update time This is the time between regular updates of data that will 
be sent whether the data has changed or not. 

1 – 63 seconds, 1-63 minutes 

Communications Port This is the Network Port in this, the receiving node, to 
which the network containing the remote (source) node is 
connected. 

Refer to the relevant product 
template file for network ports 
available on specific product 
suitable for subscriptions. 

Destination DIT Start Address This is the first DIT register address where the data will be 
written in this receiving node. 

0 – 65535 

Source Node Address This is the node address of the sending or source node 
from where the required data originates. 

This can be expressed as a local network address plus 
the local slot and port to which the network is connected, 
or it can be expressed as a global network address if 
network routing is configured in the CPU. 

0-65535 on Conet/r 

0-126 on Conet/c (local) 

128-254 on Conet/c (global) 

Source DIT Start Address This is the first DIT register address of the block of 
registers to be sent from the source node. 

0 – 65535 

Data Range This is the number of 16 bit DIT registers that will be 
transferred in the subscription. 

1 – 120 

Table 6-1 Subscription Configuration Information 

Subscriptions are configured in Omniset as follows: 

 
 
When subscription configuration is changed, messages to are sent to the sender of the data to 
cancel the subscription to ensure superfluous data is not transmitted on the network. These are 
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referred to as cancellation messages. In most cases these parameters are not required to be 
altered, but depending on atypical network considerations, it may be necessary to alter these 
settings as follows: 

 

6.4 Number of subscriptions allowed 
There is a limit to the number of subscriptions that a Teleterm M2 RTU can receive, and a 
limit to the number of subscriptions that it can send. The M2 RTU can be configured to 
receive subscriptions from a maximum of 16 other nodes and can send subscriptions to a 
maximum of 8 other receiving nodes. 
In other words each M2 RTU can act as data receiver for 16 subscriptions, and data sender 
for up to 8 subscriptions simultaneously. 

6.5 Subscription Application Example 
Refer to the diagram of a simple network below: 
 

C O N ET

N ode A ddress 2 N ode A ddress 5

N ode 2 subscribes to
data from  N ode 5

 
 
Remote node 5 on the CONET network has digital input information in DIT register 250. 
Node 2 needs to monitor these digital inputs and copy the status to its digital outputs. A 
regular update time of every 10s is quite satisfactory to determine that the remote system is 
still connected and functioning if nothing changes, but the data should be sent immediately 
if any of the digital inputs changes state. 
Node 2 is the Destination node (it sets up the subscription and receives the data). Node 5 is 
the sending node, and requires no user configuration to participate in the subscription 
process. 
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Fill in the following data into one of the eight subscription blocks in the Subscription Table in 
the M2 of Node 2 to configure this function: 
 

 

Table 6-2 Subscription Block Data Example 

 
When configured, Node 2 automatically requests a subscription with the data from Node 5 
on the Conet network. 
Node 5 undertakes to send the contents of its own DIT register 250 over the network to 
node 2 whenever any of the bits change, or every 10s if no change occurs in that time. The 
information will be placed in node 2's DIT register 260 – the digital output status register. 
Node 2 can monitor the status of the subscription by monitoring the relevant bit in the 
Subscription Status DIT register. If this bit is clear then the subscription is operating 
successfully. If this bit is set, then the subscription has failed and received data is not valid, 
or the subscription has not been correctly set. 
Be sure to configure the I/O Points for Node 5 as digital inputs and the I/O Points for Node 2 
as digital outputs.  
A few seconds after the subscription has been configured, communications will commence 
between the nodes as evident from the Tx and Rx LEDs for the Conet/c port flashing. 
Energising inputs on Node 5 will result in the corresponding output on Node 2 being 
energised. 
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7. Conet Subnet Routing 

7.1 Introduction 
The Teleterm range of RTU’s is equipped with Conet networking capability. Conet is the 
peer-to-peer networking technology used in many Omniflex products to implement powerful 
features such as remote programming and data subscriptions. 
Conet networks can operate over various physical media such as existing plant cabling, 
Ethernet, and various radio carrier networks. The following table lists the available Conet 
physical media supported: 
 

Conet Network Physical Medium Comment 
Conet/c Twisted pair cables This is the original rugged Conet cable 

network that operates over just about any 
grade twisted pair cable up to 10km in some 
cases. 

Conet/s RS232E 
 

This is a point-to-point network used 
commonly for programming Omniflex 
products. 

Conet/e Ethernet Allows peer-to-peer communication over 
conventional Ethernet networks. 

Conet/r Short range 
wireless 

This is actually a suite of radio networks 
depending upon the radio frequency of 
operation. Different versions of Conet/r are 
available in different countries depending 
upon the frequency bands allowed: 
Conet/r1 – 2.4GHz (suitable for most 

countries) 
Conet/r3 – 868MHz FSK (suitable for most 

European countries) 
Conet/r4 – 920MHz FHSS (suitable for USA, 

Australia and New Zealand) 
 
 
Many of the Teleterm M2 products also have the capability to communicate across different 
Conet networks – for example the ability to communicate through the serial or Ethernet port 
of an M2R RTU directly over the radio network with remote M2R RTU’s on the network. 
For the Teleterm M2R radio RTU’s this also includes the ability act as a repeater to extend 
the range of radio networks when line of sight is impossible to achieve. 
The capability also exists in the Teleterm M2 RTU’s to convert between the supported Open 
protocols and the Conet networks, allowing you to communicate for example with remote 
RTU’s over the radio network using the Modbus/TCP protocol, as if those remote RTU’s are 
on the Modbus network. 
These capabilities are collectively called “Conet Subnet Routing”. 
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7.2 Conet Subnet Routing Concepts 
7.2.1 Nodes 

A “node” is the term used to describe the device connected to a Conet network. If 
there are five devices connected to a network, then that network is said to have 5 
nodes. 
 

7.2.2 Node Addressing 
Each node on a Conet network is given a unique address called an “ID”. These 
addresses are up to 16 bits in size giving a theoretical address range of 0 to 65535. 
If a device has got more than one communication port, then each port can be a node 
on a different network, and will have its own “node address” or “node ID”. 
 

7.2.3 Subnets 
The 16 bit address range in Conet networking is segmented into smaller networks 
called subnets. The subnet is automatically implied from the Conet address. 
 Up to 30 subnets are supported. There can up to 999 nodes (addresses) per subnet 
as follows: 
 

Address Range Subnet Comment 
1-999 0 Reserved for Conet/c as a subnet 

1001-1999 1 All subnet addresses should start at 1001 
2001-2999 2 Subnet 2 addresses 
3001-3999 3 Subnet 3 addresses 

etc.   
30001-30999 30 Subnet 30 adresses 

 
The ‘thousands’ in the Conet address implies the subnet number for that address. A 
node that is part of a Conet intranet is addressed by combining the Subnet number of 
the subnet the node finds itself in, with the node number of the node in the subnet. 
e.g. Node number 3 in subnet 5 is addressed as 5003. This forms the identity of a 
node in a Conet network. 
Subnet 0 is reserved for legacy products that don’t implement Conet Subnet Routing. 
Therefore we typically start numbering subnets from 1, and therefore Conet subnet 
addresses from 1001. 
 

7.2.4 A Conet Intranet 
A collection of Conet subnets that are configured to operate together using Conet 
Subnet Routing is called a Conet Intranet. 
Any node on a Conet intranet is able to communicate with any other node anywhere 
else on the Conet intranet using “subnet routing”. This includes radio repeating when 
the radio nodes are on different Conet subnets. 
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7.3 Conet Subnet Routing Examples 
The best way to explain Conet Subnet Routing is by way of example. The following 
examples progressively introduce the different concepts of Conet Subnet Routing. 
These examples assume that you are familiar with the Omniset Configuration Software and 
how to configure Teleterm M2’s using this software tool. For further information see Section 
3 of this Manual. 
 
7.3.1 Example 1 – Simple point-to-point radio network using subscriptions 

This example describes a simple point to point radio system where one radio copies 
data from the other radio using subscriptions. In this example we will be reading the 
alive counter of one M2R radio node periodically into another M2R radio node. 

7.3.1.1. STEP 1 – Sketch Your Network 
The best way of designing your system is by starting with a simple sketch of 
the system and allocating the subnets and node addresses on your sketch. 
This assists in visualising your network, and you will find this invaluable in 
later troubleshooting on site. 
 
This system consists of two Teleterm M2R’s on the same radio Subnet. We 
allocate the first available Subnet number (1). This gives allowable addresses 
in this subnet in the range 1001 to 1999. 
Allocate Conet ID’s for each node in the subnet. In this case we allocated 
Conet ID’s 1001 and 1002. 
 

Subnet 11001

Radio Network

1002

Read Alive Counter
every 5 seconds

 
 

7.3.1.2. STEP 2 - Program the Radio Node Address 1002 on the second M2R 
Under “Communications>Port Setup” in Omniset: 
 

 
 
“Conet Subnet Routing Start” and “Conet Subnet Routing Stop” values can be 
left at 0 in this case because we are not doing subnet routing on the radio port. 
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7.3.1.3. STEP 3 – Program the Radio Node Address 1001 on the first M2R 
Under “Communications >Port Setup” in Omniset: 

 
 
“Conet Subnet Routing Start” and “Conet Subnet Routing Stop” values can be 
left at 0 in this case because we are not doing subnet routing on the radio port. 
 

7.3.1.4. STEP 4 - Configure a subscription on the first M2R [1001] to retrieve the alive 
counter from the second M2R [1002]: 
Under “Communications>Subscriptions>Blocks 1-8” in Omniset: 
 

 
 

7.3.1.5. Observe the Working Example 
Every 5 seconds Node1002’s alive counter (DIT 23) will be copied to Node 
1001 (DIT 500). 
Observe the TX LED flash on Node 1002 and the RX LED flash on Node 
1001 every 5 seconds. 
Check the Alive Counter value being written every 5 seconds to DIT register 
500 
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Check the Subscription Status: 
 

 
 

7.3.2 Example 2 – Simple point-to-point radio network using subscriptions with COS 
This example is similar to Example 1, but this time we are going to read the digital 
Inputs from Node 1002 and write them to the outputs of Node 1001, using Change-Of-
State subscriptions to improve system response time while reducing communications 
traffic. 

7.3.2.1. STEP 1 – Sketch Your Network 
This system consists of two Teleterm M2R’s on the same radio Subnet. We 
allocate the first available Subnet number (1). This gives allowable addresses 
in this subnet in the range 1001 to 1999. 
Allocate Conet ID’s for each node in the subnet. In this case we allocated 
Conet ID’s 1001 and 1002. 
 

Subnet 11001

Radio Network

1002

Read Inputs and write to
outputs on change of state

 
 

7.3.2.2. STEP 2 - Program the Radio Node Address 1002 on the second M2R 
Under “Communications >Port Setup” in Omniset: 
 

 
 
“Conet Subnet Routing Start” and “Conet Subnet Routing Stop” values can be 
left at 0 in this case because we are not doing subnet routing on the radio port. 
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7.3.2.3. STEP 3 - Program the IO on the second M2R to be 12 Digital Inputs 
Under “Configuration>I/O Points” in Omniset: 
 

 

7.3.2.4. STEP 4 – Program the Radio Node Address 1001 on the first M2R 
Under “Communications >Port Setup” in Omniset: 

 
 
“Conet Subnet Routing Start” and “Conet Subnet Routing Stop” values can be 
left at 0 in this case because we are not doing subnet routing on the radio port. 
 

7.3.2.5. STEP 5 - Program the IO on the first M2R to be 10 Digital Outputs. 
(Note IO points 11 and 12 cannot be set to digital outputs) 
Under “Configuration>I/O Points” in Omniset: 
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7.3.2.6. STEP 6 - Configure a subscription on M2R [1001] to read the digital input 
register from M2R [1002] and write it to the outputs of M2R [1001]. 
Under “Communications>Subscriptions>Blocks 1-8” in Omniset: 
 

 
 
In this example we are using Change of State Subscriptions, so that the 
change of any input is transmitted immediately to Node 1001, avoiding the up 
to 5 second delay if a cyclic only query were used. 
 

7.3.2.7. Observe the working Example 
Energise Input 1 on the second M2R. The input LED will light, and the 
transmit light will flash immediately. 
Note the Receive light on the first M2R flash, and Output 1 LED will light and 
the output will energise. 
Every 5 seconds Node1002 will send an update of the digital input status to 
Node 1001 to ensure that the IO stays in sync even when no changes are 
occurring. 
 
Check Subscription Status: (under 
RealtimeData>Communications>Subscription Status) 
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7.3.3 Example 3: Modbus/TCP Polling 
In this example, we are going to poll both M2Rs using Modbus/TCP from a Windows 
PC running Omniset. For this example, the first M2R must support a built in Ethernet 
port (i.e. Model C2361C-34-x.). (This example only needs slight modification to use 
Modbus through the serial port S2 of the first M2R instead). 
 
For convenience we are going to use the same PC for both configuration and 
Modbus/TCP polling but of course in real life these are likely to be different. 
 
Conet Subnet Routing provides an additional feature that allows the 8-bit address limit 
of the Modbus protocol to be mapped to up to 254 Nodes on a Conet Subnet network. 
This allows the Modbus Master to “see” these nodes as Modbus slave devices 
connected directly to it when in fact they are distributed over the Conet intranet. 
 
To accomplish this we have to allocate a subnet for the Modbus network as well as 
provide an address map of Modbus Slave address to Conet Subnet IDs as per the 
procedure outlined below: 
 

7.3.3.1. STEP1 - Draw the system picture and allocate subnets. 
In this example the Modbus/TCP network must also be assigned as a subnet 
in the Conet Intranet. 
The subnet for the Ethernet port is typically allocated as subnet 30 to allow 
room for expansion when allocating other radio subnets for the future. 
 
 

Radio Network

M2R
1001

M2R
1002

1
subnet

30
subnet

Conet/s to 
Prog port (S1)

Modbus/TCP (Ethernet)

[Modbus ID 1]

[Modbus ID 2]  
 
 

 
 

7.3.3.2. STEP 2 - Allocate Radio Subnet ID’s for the radio network (1001, 1002) 
Allocate these numbers as required to the sketch. 
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7.3.3.3. STEP 3 - Allocate Equivalent Modbus addresses 
We wish to read the two M2R’s using Modbus, and so they each have to be 
allocated a Modbus Address. Modbus addresses are in the range from 1 to 
254. In this case we allocate 1 for the directly connected M2R and 2 for the 
other M2R node on the network. 
Allocate these numbers as required to the sketch 
 

7.3.3.4. STEP 4 - From the sketch configure the Radio Port settings as follows: 
 
For Radio Node 1001 (under “Communications”>”Port Setup”): 
 

 
 
“Conet Subnet Routing Start” and “Conet Subnet Routing Stop” values can be 
left at 0 in this case because we are not doing subnet routing on the radio port. 
 
For Radio Node 2002: 

 
 
 
 

7.3.3.5. STEP 5 - Configure the Ethernet Port Settings. 
Set the Modbus/TCP Port Number to 1. Set the Ethernet IP Address 
compatible with your Ethernet network. (The selection of IP address is outside 
the scope of this example). (configure under “Communications”>”Port Setup”) 
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7.3.3.6. STEP 6 – Configure the Conet Subnet Settings for the Ethernet Port 
In “Conet Subnet Routing>Modbus/TCP Ethernet Port”: 
Set the Conet Subnet of Ethernet Port to 30. 
Set the mapping of Modbus Slave ID to Conet Address. 
Note: We do not need to enter the Conet subnet ID for slave 1 as slave 1 is 
this node, and will be addressed directly. 
 

 
 

7.3.3.7. Configure the Subnet Routing Table in each node 
The Routing Table tells the node where to send messages destined for 
another subnet. Apply the following procedure to configuring the Subnet 
routing table.  
 
Node 1001: 
Identify the subnets connected to this node and on which port: 
Subnet 1 is connected on radio port. 
Subnet 30 is connected on the Ethernet (Modbus TCP) port. 
 
Always enter node’s own ID as the Router ID for the node’s own subnet. So in 
this case the Router ID for Subnet 1 will be the node’s own address [1001].  
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Messages from this node intended for nodes on subnet 30, must be sent via 
Node Address 30001 on this node.  
Therefore we configure 30001 as the router Id for subnet 30. 
Note: the ID of 30001 is a derived Conet subnet ID taken from the Modbus 
Slave address of 1 and the configured Conet subnet of 30. 
 

 
 
Node 1002: 
Identify the subnets connected to this node and on which port: 
Subnet 1 is connected on radio port. 
Subnet 30 is also connected on the radio port via node 1001. 
 
Again, enter own ID [1002] as the router ID for own Subnet. 
 
In this example, messages intended for nodes on subnet 30, must be sent via 
Node 1001. Therefore we configure 1001 as the router ID for subnet 30 in this 
node. 
 

UMC236xCR045.pdf 58 -© Omniflex 
 



Teleterm M2 Series RTU User Manual  

 

 

 
 

7.3.3.8. Observe the Working Example 
At this stage all the configuration is complete. 
 
Note that in a Conet Subnet Routing system it is possible to connect the 
Programming cable into a Prog port on any node in the system and be able to 
communicate to any other node. 
Plug the programming cable into Node 1001’s Prog port.  
In Omniset set target node address to 1001 as shown and observe 
communication with the connected node. 
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Now set the target node address to communicate to node 1002 by setting the 
Network ID to 1002 as shown and observe communication to node 1002. 
 

 
 
 
Now set Omniset to Modbus/TCP, and enter the IP address of unit 1001. 
Ping the unit. If the ping is successful, set the network ID to 1 and observe 
communication to node 1001. 
Now set the network ID to 2 and observe communication to node 1002. 
 

 
 
 
 
Now an OPC server (or any Modbus/TCP master) can be connected via the 
Ethernet port and all the nodes can be polled. 
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7.3.4 Example 4 – Radio Repeating using Conet Subnet Routing 
In this example, another Radio Subnet will be added to our Example 3 and it will link 
with the current system via an additional Radio Node acting as a Radio Repeater. 

7.3.4.1. STEP 1 - Sketch the new network configuration and allocate the addresses. 
 

 

Radio Network

M2R
1001

M2R
1002

1
subnet

30
subnet

Conet/s to 
Prog port (S1)

Modbus/TCP (Ethernet)

Radio Network

2
subnet

M2R
1003

M2R
2001

 
 
Subnet 1 and Subnet 2 are two radio networks that are not in contact except 
for one node that is in range of both subnets. This Node could be part of 
either subnet. In this case it is part of subnet 1 and we give it a Radio Subnet 
ID = 1003. 
 
We identify the second subnet as Subnet 2 and we allocate Radio Subnet 
ID’s for the nodes in this subnet. The example node in Subnet 2 is given a 
Subnet ID of 2001.  
 
We also need to allocate Modbus Addresses if we wish to talk to these 
additional nodes using Modbus/TCP. 
In this case we allocate Modbus Address 3 for Node 1003 and 4 for Node 
2001. 
 

7.3.4.2. STEP 2 – Configure the new Radio Node Addresses 
Configure the node addresses for new nodes 1003 and 2001 in 
“Communications > Port Setup” 
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In this example we are using Conet Subnet Routing on the radio network and 
so we need to configure “Conet Routing Subnet Start” and “Conet Routing 
Subnet Stop” values. See the next step. 
 

7.3.4.3. STEP 3 - Set Subnet Ranges for Nodes 1003 and 2001. 
 
Because we are using multiple radio subnets with eom M2R’s as radio 
repeaters, we need to configure in each node which subnets are accessed 
through the radio port. 
In this example our radio system operates on subnets 1 and 2. Configure 
Configure “Conet Routing Subnet Start” = 1 and 
“Conet Routing Subnet End” = 2 in each M2R in the system. 
 

For Node 1003 (and any other nodes on Subnet 1) we configure Conet 
Routing Subnet Start of 1 and End of 2 as shown below. 

 

 
For Node 2001 (and any other nodes on Subnet 2) configure a Routing 
Subnet Start of 1 and End of 2 and shown. 
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7.3.4.4. STEP 4 - Complete the Modbus Address Mapping 
Now we need to go back and add the new Modbus Slave Addresses to the 
Modbus address map in Node 1001. 
Connect to Node 1001 and under “Conet Subnet Routing” -> “Modbus/TCP 
Ethernet Port” enter the subnet ID’s for Modbus Slaves 3 and 4.  

 

 
 

7.3.4.5. STEP 5 - Configure the Subnet Routing Tables: 
 
Node 1001:  
Node 1001 has to route through node 1003 to reach Subnet 2. 
So enter 1003 as the router ID for Subnet 2. 
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Node1002: 
Node 1002 has to route through node 1003 to reach Subnet 2. 
So enter 1003 as the router ID for Subnet 2. 

 

 
 

Node1003 
Node 1003 can send directly to Subnet 2. It is in effect using itself as a Router 
because it is addressed as a member of Subnet 1. 
So enter 1003 as the router ID for Subnet 2. 
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Node 2001: 
Node 2001 needs to route through Node 1003 to communicate with Nodes on 
Subnet 1 and 30. So enter 1003 for these subnets. 
Enter Own ID for Own Subnet. 
 

 
 

7.3.4.6. Observe the working example 
 
Plug the programming cable into Node 1001’s prog port.  
In Omniset set target node address to 1001 as shown and observe 
communication with the connected node. 
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Now set the target node address to communicate to node 1002, 1003 and 
2001 by changing the Network ID In Omniset as shown below and observe 
communication to all the nodes is possible.  
 

 
 
 
Now set Omniset to Modbus/TCP, and enter the IP address of unit 1001. 
Ping the unit. If the ping is successful, set the network ID to 1, 2, 3, 4 and 
observe communication to all the nodes. 
 

 
 
 
 
Now an OPC server (or any Modbus/TCP master) can be connected via the 
Ethernet port and all the nodes can be polled. 
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7.3.5 Example 4: Adding a conet/e Subnet 

In this example we will add a Conet/e network to the system. This example assumes 
that you have the network in example 4 already operational. 
 
Conet/e is part of the Conet protocol which works on the Ethernet physical layer. In 
this example, we going to use Conet/e to communicate with Node 1001 and hence all 
the nodes in the network. This will allow us to use IsaGRAF to program all the nodes 
in the network via an Ethernet connection to Node 1001.  

 

Radio Network
M2R

1001
M2R

1002

1
subnet

30
subnet

Conet/s to 
Prog port (S1)

Modbus/TCP (Ethernet)

Radio Network

2
subnet

M2R
1003

M2R
2001

29
subnet

29002

Conet/e (Ethernet)

[Modbus ID 1] [Modbus ID 2]

[Modbus ID 3]

[Modbus ID 4]  
 

7.3.5.1. STEP 1 – Add this network to our sketch 
In this case we assign the subnet ID 29 to the Conet/e subnet, and 
consequently an ID of 29002 to the Conet/e port on the M2Re in the system. 
(The computer is ID 1) 

7.3.5.2. STEP 2 - Program the Conet/e port unit ID on unit 1001 
 

 

7.3.5.3. STEP 3 - Program the Conet Subnet Routing tables: 
 
Node 1001: 
Add the Router ID for Subnet 29 (29002). This means that any messages 
reaching this node destined for Subnet 29 get routed to Subnet ID 29002. 
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Node 1002:  
Add the router ID for subnet 29. In this case node 1002 has to route through 
node 1001 to reach node 29. So the Router ID for Subnet 29 is 1001. (This 
applies to all radio nodes in subnet 1.) 
 

 
 
Node 1003: 
Add the router ID for subnet 29 as in Node 1002 above.  
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Node 2001: 
This node is in subnet 2 and hence has to route through node 1003 (the 
router node into Subnet 1) to reach subnet 1 and therefore subnet 29. So the 
router ID for Subnet 29 in this case is 1003.  
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7.3.5.4. Configuration is now complete. In Omniset, change the port to Conet/e. 
 
Enter the IP address, and select any network ID (1001, 1002, 1003 or 2001) 
to communicate with. Verify that communication to all the nodes is possible. 
 

 
 

7.3.5.5. Now we can set IsaGRAF up to program any RTU in the network using 
conet/e (connected via Ethernet to Node 1001). To set the conet/e link on 
IsaGRAF, click on “Link Setup”. (In the ‘Programs Window’ click on 
“Debug”>”Link Setup”). For more info on IsaGRAF please refer to section 8 of 
this manual. 
 
Set Communication Port to Conet Server. 

 
 
Click Setup  - Set the IP address and the Direct/Global Network ID to any of 
the Subnet ID’s and click OK. It will now be possible to program/monitor any 
of the nodes in the network. 
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8. Programming the M2 with ISaGRAF 

8.1 Optional ISaGRAF programming 
Each of the Teleterm M2 series RTU’s can be shipped with ISaGRAF programming 
capability. Products with ISaGRAF installed are identified from the Order Code on the label 
on the rear of the unit  (e.g. C236xB-nn-1 ) as well as a label on the top cover “ISaGRAF 
enabled”. 
 

8.2 Introduction to IEC61131-3 Programming 

8.2.1 The IEC61131 Standard 
The IEC61131 standard was created to fulfil the need for standardisation in PLC 
programming languages. 
The IEC61131 standard is divided into a number of parts: 

Part 1 General information Definition of basic terminology and concepts. 
Part 2 Equipment requirements and tests Electronic and mechanical construction and 
verification tests. - published 1992 
Part 3 Programmable languages PLC software structure, languages and program execution. 
Part 4 User guidelines Guidance on selection, installation, maintenance of PLC’s. 
Part 5 Messaging service specification Software facilities to communicate with other devices 
using communications based on MAP Manufacturing Messaging Services. 
Part 6 Communications via fieldbus Software facilities of PLC communications using IEC 
fieldbus 
Part 7 Fuzzy control programming Software facilities, including standard function blocks for 
handling fuzzy logic within PLC’s - published 1997 
Part 8 Guidelines for the implementation of languages for programmable controllers Application 
and implementation guidelines for the IEC61131-3 languages. 

The part applicable to PLC programming is IEC61131-3. The Teleterm M2 series 
together with the Application Workbench conforms to this IEC standard for 
programming languages. 
 

8.2.2 The IEC61131-3 Programming Languages 
The IEC61131-3 standard defines 5 programming languages: 
• Sequential Flow Chart (SFC) 

A graphical language for depicting sequential behaviour of a control system. It is 
used for defining control sequences that are time and event driven. 
Sequential Function Chart (SFC), the core language of the IEC 61131-3 standard, 
divides the process cycle into a number of well-defined steps, separated by 
transitions. The other languages are used to describe the actions performed within 
the steps and the logical conditions for the transitions. Parallel processes can 
easily be described using SFC. 

• Function Block Diagram (FBD) 
A graphical language for depicting signal and data flows through function blocks - 
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re-usable software elements. FBD is very useful for expressing the interconnection 
of control system algorithms and logic. 

• Ladder Diagram (LD) 
A graphical language that is based on relay ladder logic - a technique commonly 
used to program current generation PLC’s. However, the IEC Ladder Diagram 
language also allows the connection of user defined function blocks and functions 
and so can be used in a hierarchical design. 

• Structured Text (ST) 
A high level textual language that encourages structured programming. It has a 
language structure (syntax) that strongly resembles PASCAL and supports a wide 
range of standard functions and operators. 
This language is primarily used to implement complex procedures that cannot be 
easily expressed with graphical languages (e.g. IF / THEN / ELSE, FOR, 
WHILE...).  

• Instruction List (IL) 
A low level 'assembler like' textual language that is based on similar instruction list 
languages found in a wide range of today's PLC’s. 

 
The Teleterm M2 RTU implements all 5 of these IEC61131-3 languages as well as a 
sixth language called “Flow Chart”. 
• Flow Chart (FC) 

Recognizing that virtually every engineer graduating from college today has 
programmed in Flow Chart, the Workbench fully supports graphical Flow Chart 
programming. The Flow Chart is an easy to read decision diagram where actions 
are organized in a graphic flow. Binary decisions are used to control the flow. The 
Flow Chart Editor has full support for connectors and sub-programs. Actions and 
tests can be programmed in LD, ST or IL. 

 

8.3 Programming the Teleterm M2 RTU 
The Teleterm M2 RTU can be programmed in any of the supported languages with the aid 
of the Omniflex ISaGRAF Programmer’s Workbench. 
For program development, the Application Workbench provides powerful and intuitive 
Windows based graphical and textual editors with drag-and-drop, and cut-and-paste to 
enhance ease of use. 
 
The Application Workbench offers the following features: 
• Project Management 
• I/O Definition 
• Modular Programming 
• Simulation 
• Real-time on-line debugging 
• Document Generation 
 
Full instructions on the use of the Application Workbench are available in a separate 
manual. 
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This manual is restricted to instructions specific to the Teleterm M2 RTU. 
 

8.4 Installing the Omniflex ISaGRAF Application Workbench for the Teleterm M2 RTU. 
The Omniflex ISaGRAF Application Workbench installs together with the Omniset Pro 
configuration utility. This software suite allows remote programming as well as providing 
simultaneous access to the CPU by Omniset for remote configuration. 
See the Application Workbench installation instructions supplied with the software to install 
the Application Workbench with Omniset Pro. 
 

8.5 Setting up the Application Workbench for the Teleterm M2 RTU. 
The following settings in the workbench are applicable for the Teleterm M2 RTU’s: 
 
From the Start Menu, select “Omniflex>ISaGRAF>Projects”. 
Start a new Project or open an existing Project. 
Then set the following parameters as directed below: 
 

8.5.1 PC-PLC Link Parameters 
1. On the “Debug” menu, select “Link Setup”. 
2. Select all parameters as shown below. For remote programming over slow links, 

the Time out value may need to be increased if timeouts occur: 
 

 
 

3. Select “Setup” and then choose the desired Conet Port and Target Address for 
communicating with theTeleterm M2 RTU.  
 
Programming of the Teleterm M2 can be performed via any of the following links: 
• Via the programming port (S2) (using Conet/s through a serial port on your PC) 
• Via the optional Ethernet port (using Conet/e through an Ethernet port on your 

PC. 
• Via the Conet/c network port of the Teleterm M2C (requires an Conet PCI card 

installed in your computer, or an external Conet gateway.) 
• Via the serial port (S1) (using Conet/s through a serial port on your PC) 

The serial port of the M2 must be set to Conet/s protocol. 
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4. For communicating with the Teleterm M2 RTU through the programming port via a 
serial port on your computer, select the following settings (Note: The actual COM 
port number may vary on your computer, depending upon which COM port you 
selected when installing the ISaGRAF Workbench: 
 

 
 
An IP Address is only required if communicating using Conet/e over Ethernet. 
Select “Local CPU” to connect with the RTU over any of the ports. 

8.5.2 I/O Slot and Channel Numbering 
You now need to ensure that the Slot Numbering starts from 0, and the Channel 
Numbering starts from 1 as follows: 
In your open Project: 
1. From the “Project” menu, open the “I/O Connection” Window. 
2. From the “Options” menu in this window, select “Numbering”  
Check that your settings match the following: 
 

 
 

8.5.3 Compiler Options 
Ensure that the following compiler options are selected in your Application Workbench 
for use with your Teleterm M2 RTU: 
From within your open project: 
1. Start a new Program or open an existing program in the project (any language) as 

follows: 
To start a new program select File New. You will get the following dialogue box: 
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Fill in a program name, select a language, and then press OK. 
The program will appear in the project window 
 

 
 
To open a program,  select the program in the window and then select File Open, 
(or double click the program name in the window) 
 

2. In the Program Window, select “Compiler options” from the “Options” menu 
 

 
 
Ensure that the “SIMULATE” and “ISA68M” (TIC code for P3 & C236xC) 
options are both selected in the “Targets” list. To select an option in the list. Click 
on the item and press the “Select” button. 
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You can also select any compile optimisations that you require at this stage. 
(These can also be selected at any time in he future in the same way). 

 

8.6 Creating I/O Connections 
You must define the virtual I/O Modules in your project in accordance with the physical 
configuration of I/O Points in the Teleterm M2 RTU target. 
If the virtual I/O modules in the project do not match the configuration of the Teleterm M2, 
then your program cannot be started. 
To define the I/O Point modules in your project: 
1. Start a new Project or open an existing Project. 
2. From the “Project” menu, select “I/O Connection” (or use the “I/O Connection” button 

on the toolbar). 
3. Select the I/O Module position to be defined. 

The following table gives the physical I/O Point module positions in the Teleterm M2 
vs the ISaGRAF Slot Numbers in this dialogue box: 
 

ISaGRAF 
Slot No. 

I/O Point 
No. 

Comments 

0 0 Install the M2 Supervisor virtual module here 
1 1 Install the relevant M2 I/O Point virtual module 
2 2 Install the relevant M2 I/O Point virtual module 
3 3 Install the relevant M2 I/O Point virtual module 
4 4 Install the relevant M2 I/O Point virtual module 
5 5 Install the relevant M2 I/O Point virtual module 
6 6 Install the relevant M2 I/O Point virtual module 
7 7 Install the relevant M2 I/O Point virtual module 
8 8 Install the relevant M2 I/O Point virtual module 
9 9 Install the relevant M2 I/O Point virtual module 

10 10 Install the relevant M2 I/O Point virtual module 
11 11 Install the relevant M2 I/O Point virtual module 
12 12 Install the relevant M2 I/O Point virtual module 
13 

onwards 
 Other virtual Modules can be installed in any of 

the unused ISaGRAF slots. 
 

4. Select “Set Board/Equipment” from the “Edit” menu. (This selection can also be made 
by double clicking the Slot Number). 

5. The Application Workbench separates I/O modules that have a single type of 
Input/Output from those with multiple Input/Output Types. 
Select “Boards” in the Library box to display all virtual I/O Modules with a single 
Input/Output type, or “Equipments” to display all virtual I/O Modules with multiple 
Input/Output types. 
All Teleterm M2 specific virtual I/O Modules have names that begin m2xxx. 
You can view more information about each module using the “Note” button. 

6. Select the desired virtual I/O module and press “Ok” to insert the module in the current 
slot. 
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7. Once Input and Output variables have been defined in your project dictionary, you can 
connect these variables to the appropriate virtual I/O Module in this window by selecting 
“Select Channel/Parameter” from the “Edit” menu or double clicking the desired Channel 
number on the selected Slot. 
NOTE: 
Some virtual I/O modules have “parameters” which must be set for the correct operation 
of those modules. See a full explanation in the Note attached to the Maxiflex Module. 

 

8.7 Programming with the DIT 
The Data Interchange Table provides a versatile repository for all data used within the 
Teleterm M2 RTU. This data may be accessed in a User Program in a number of ways: 

8.7.1 Using DIT Functions to access data in the DIT 
A number of functions are available in the Application Workbench to access Data in 
the DIT. These can be found in the pull-down list of Functions available when editing a 
program in the FBD language, or by entering these functions as text in the ST or IL 
languages. 
NOTE: These functions are implemented immediately, and are NOT synchronised to 
the program scan. This has the consequence that data is written to the DIT when the 
function is implemented, and this data is available immediately for use in the same 
program scan. 
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8.7.1.1. DITRD - Read a DIT register 

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address to be read 
VAL OUT Integer The 16-bit value read from the DIT Register 

 
Description: 
Use this function to read an integer from a local DIT register. 
This function cannot be used to access the extended DIT Range 
 

8.7.1.2. DITWR - Write a value to a DIT register 

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address to be written 
VAL IN Integer The 16-bit value to write to the DIT Register 
F OUT Boolean “True” if write is successful 

 
Description: 
Use this function to write a 16 bit integer to a local DIT register. 
The integer must be in the range –32768 to 32767 
This function cannot be used to access the extended DIT Range. (Use the 
MxDIT_CPY function to copy extended DIT’s to/from an unused local DIT area). 
 
 
 
 

8.7.1.3. DITBITRD - Read a bit from a DIT 

 
Arguments: 
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Name In/Out Type Description 
DIT IN Integer The DIT Register Address to be read 
BIT IN Integer The BIT of the DIT register to be read. 

BIT must be in the range 0 to 15. 
BIT 0 is the least significant bit. 
BIT 15 is the most significant bit. 

STATUS OUT Boolean The Bit value read from the DIT Register 
 
Description: 
Use this function to read a BIT from a local DIT register as a Boolean. 
 

8.7.1.4. DITBITWR - Write a bit in a DIT 

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address to be written to  
BIT IN Integer The BIT of the DIT register to be written to. 

BIT must be in the range 0 to 15. 
BIT 0 is the least significant bit. 
BIT 15 is the most significant bit. 

STATUS IN Boolean The Bit value to be written 
F OUT Boolean “True” if write is successful 

 
Description: 
Use this function to write a Boolean value to a BIT in a local DIT register. 
 

8.7.1.5. DITRDD - Read a double word from the DIT  

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address from which to read the 

double word.  
DVAL OUT Integer The 32-bit double word read from the register 'DIT' 

and 'DIT +1' 
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Description: 
Use this function to read a double word from a local DIT register.  
NOTE: the word order for a double word read from DIT register n is as follows: 

DIT n  = Most significant word 
DIT n +1 = Least significant word 

This function cannot be used to access the extended DIT Range. 
 

8.7.1.6. DITWRD - Write a double word to the DIT  

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address at which to write the double 

word.  
DVAL IN Integer The 32-bit double word to be written to register 'DIT' 

and 'DIT +1' 
F OUT Boolean “True” if write is successful 

 
Description: 
Use this function to write a double word to a local DIT register.  
NOTE: the word order in the double word written to DIT register n is as follows: 

DIT n  = Most significant word 
DIT n +1 = Least significant word 

This function cannot be used to access the extended DIT Range. 
 

8.7.1.7. DITRDDX - Read a double word from the DIT, swapped  

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address from which to read the 

double word.  
DVAL OUT Integer The 32-bit double word read, in reverse word order, 

from the register 'DIT' and 'DIT +1' 
 
Description: 
Use this function to read a double word from a local DIT register.  
NOTE: the word order for a double word read from DIT register n is as follows: 
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DIT n  = Least significant word 
DIT n +1 = Most significant word 

This function cannot be used to access the extended DIT Range. 
 

8.7.1.8. DITWRDX - Write a double word to the DIT, swapped  

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address at which to write the double 

word.  
DVAL IN Integer The 32-bit double word to be written, in reverse word 

order, to register 'DIT' and 'DIT +1' 
F OUT Boolean “True” if write is successful 

 
Description: 
Use this function to write a double word to a local DIT register.  
NOTE: the word order in the double word written to DIT register n is as follows: 

DIT n  = Least significant word 
DIT n +1 = Most significant word 

This function cannot be used to access the extended DIT Range. 
 

8.7.1.9. DITRDR - Read a real number from the DIT  

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address from which to read the real 

number.  
RVAL OUT Real The 32-bit IEEE floating point real number read from 

register 'DIT' and 'DIT +1' 
 
Description: 
Use this function to read a 32-bit IEEE floating point real number from a local DIT 
register.  
NOTE: the word order for a real number read from DIT register n is as follows: 

DIT n  = Most significant word 
DIT n +1 = Least significant word 
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This function cannot be used to access the extended DIT Range. 
 

8.7.1.10. DITWRR - Write a real number to the DIT 

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address at which to write the real 

number.  
RVAL IN Real The 32-bit IEEE floating point real number to be 

written to register 'DIT' and 'DIT +1' 
F OUT Boolean “True” if write is successful 

 
Description: 
Use this function to write a 32-bit IEEE floating point real number to a local DIT 
register.  
NOTE: the word order in the real number written to DIT register n is as follows: 

DIT n  = Most significant word 
DIT n +1 = Least significant word 

This function cannot be used to access the extended DIT Range. 
 

8.7.1.11. DITRDRX - Read a real number from the DIT, swapped  

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address from which to read the real 

number.  
RVAL OUT Real The 32-bit IEEE floating point real number read, in 

reverse word order, from the register 'DIT' and 'DIT +1'
 
Description: 
Use this function to read a 32-bit IEEE floating point real number from a local DIT 
register.  
NOTE: the word order for a real number read from DIT register n is as follows: 

DIT n  = Least significant word 
DIT n +1 = Most significant word 

This function cannot be used to access the extended DIT Range. 
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8.7.1.12. DITWRRX - Write a real number to the DIT, swapped  

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address at which to write the double 

word.  
RVAL IN Real The 32-bit IEEE floating point real number to be 

written, in reverse word order, to register 'DIT' and 
'DIT +1' 

F OUT Boolean “True” if write is successful 
 
Description: 
Use this function to write a 32-bit IEEE floating point real number to a local DIT 
register.  
NOTE: the word order in the real number written to DIT register n is as follows: 

DIT n  = Least significant word 
DIT n +1 = Most significant word 

This function cannot be used to access the extended DIT Range. 
 

8.7.1.13. DITRDT - Read a timer from the DIT  

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address from which to read the timer. 
TVAL OUT Timer The timer value read from the register 'DIT' and 'DIT +1' 

 
Description: 
Use this function to read a timer from a local DIT register.  
NOTE: the word order for a timer read from DIT register n is as follows: 

DIT n  = Most significant word 
DIT n +1 = Least significant word 

This function cannot be used to access the extended DIT Range. 
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8.7.1.14. DITWRT - Write a timer to the DIT  

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address at which to write the timer.  
TVAL IN Timer The timer to be written to register 'DIT' and 'DIT +1' 
F OUT Boolea

n 
“True” if write is successful 

 
Description: 
Use this function to write a timer to a local DIT register.  
NOTE: the word order in the timer written to DIT register n is as follows: 

DIT n  = Most significant word 
DIT n +1 = Least significant word 

This function cannot be used to access the extended DIT Range. 
 

8.7.1.15. DITRDM - Read a message from the DIT  

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address from which the message 

will be read.  
LEN IN Integer The length of the message string or number of 

characters. 
MESS OUT Message Message read from the DIT table starting at 'DIT'. 

 
Description: 
Use this function to read a message from the local DIT registers. Each DIT contains 
two characters. Messages are read from the DIT in increasing DIT order. For example, 
the message 'user', stored at DIT n would be read from DIT n and DIT n+1 as follows: 

DIT n = 'u' (msb), 's' (lsb) 
DIT n+1 = 'e' (msb), 'r' (lsb) 

Always ensure that the variable connected to MESS is greater than or equal to LEN. 
This function cannot be used to access the extended DIT Range. 
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8.7.1.16. DITWRM - Write a message to the DIT  

 
Arguments: 
Name In/Out Type Description 
DIT IN Integer The DIT Register Address to which the message will 

be written.  
LEN IN Integer The length of the message string or number of 

characters. 
MESS IN Message Message written to the DIT table starting at 'DIT'. 
F OUT Boolean “True” if write is successful 

 
Description: 
Use this function to write a message to the local DIT registers. Each DIT contains two 
characters. Messages are to the DIT in increasing DIT order. For example, the 
message 'user', stored at DIT n would be written to DIT n and DIT n+1 as follows: 

DIT n = 'u' (msb), 's' (lsb) 
DIT n+1 = 'e' (msb), 'r' (lsb) 

The number of DIT registers that will be written can be calculated as follows: 
If LEN is an even number then the number of DIT’s written equals LEN/2 
If LEN is an odd number then the number of DIT’s written equals LEN/2+1 

This function cannot be used to access the extended DIT Range. 
 

8.7.2 Using “DIT” Virtual I/O Modules to access data in the DIT 
In the library of virtual I/O Modules are a number of “virtual” modules that represent 
data in the DIT as if it were an actual module. 
These virtual Modules can be used to read/write data to/from the DIT just as if it was 
data from the outside world. 
As I/O modules, these inputs and outputs can be tagged in the dictionary, and will be 
updated once per scan. 
To use these modules, assign them to an I/O slot in the normal way. I/O slots 13 to 
255 can be used for this purpose without encroaching on the real I/O Slots available in 
the system, although any I/O slot can be used for a virtual module. 
Set the DIT parameter in the module to the DIT(s) to be addressed. 
See the Descriptive Notes attached to these modules in the ISaGRAF Workbench for 
more detailed information. 
 
The following table gives a list of these available “DIT” virtual I/O Modules: 
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Name In/Out Channels Type Description 
RBI16 IN 16 Binary Reads the 16 bits from a single DIT register as 16 Binary 

Inputs. 
RBO16 OUT 16 Binary Writes 16 Binary outputs to the bits of a single DIT 

register. 
RIS1 IN 1 Integer Inputs 1 single DIT register as a 16 integer 
RID1 IN 1 Integer Inputs 2 contiguous DIT registers as a double integer. 
RID1x IN 1 Integer As per RID1 but the word order is swapped to calculate 

the double integer. 
RIF1 IN 1 Float Inputs 2 contiguous DIT registers as a 16 IEEE floating 

point number. 
RIF1x IN 1 Float As per RIF1 but the word order is swapped to calculate 

the 32 bit floating point value. 
ROS1 OUT 1 Integer Outputs 16 integers to a contiguous block of 16 single 

DIT registers. 
ROD1 OUT 1 Integer Outputs 16 integers to a contiguous block of 32 DIT 

registers – each integer occupying two consecutive 
registers as a 32 bit value. 

ROD1x OUT 1 Integer As per ROD16 but the word order is swapped when 
storing the double integer. 

ROF1 OUT 1 Float Outputs 16 IEEE floating point numbers to a contiguous 
block of 32 DIT registers – each number occupying two 
consecutive registers as a 32 bit number. 

ROF1x OUT 1 Float As per ROF16 but the word order is swapped when 
storing the number to the two consecutive DIT registers. 

RIS8 IN 8 Integer Inputs 8 contiguous single DIT registers as 8 integers 
RID8 IN 8 Integer Inputs 16 contiguous DIT registers as 8 double integers. 

i.e. Each integer is derived from a contiguous pair of 
DIT’s as a single 32 bit integer 

RID8x IN 8 Integer As per RID8 but the word order is swapped to calculate 
the double integer. 

RIF8 IN 8 Float Inputs 16 contiguous DIT registers as 8 IEEE floating 
point numbers. i.e. Each floating point number is derived 
from a contiguous pair of DIT’s as a single 32 bit floating 
point number. 

RIF8x IN 8 Float As per RIF8 but the word order is swaped to calculate the 
32 bt floating point value. 

ROS8 OUT 8 Integer Outputs 8 integers to a contiguous block of 8 single DIT 
registers. 

ROD8 OUT 8 Integer Outputs 8 integers to a contiguous block of 16 DIT 
registers – each integer occupying two consecutive 
registers as a 32 bit value. 

ROD8x OUT 8 Integer As per ROD8 but the word order is swapped when 
storing the double integer. 

ROF8 OUT 8 Float Outputs 8 IEEE floating point numbers to a contiguous 
block of 16 DIT registers – each number occupying two 
consecutive registers as a 32 bit number. 

ROF8x OUT 8 Float As per ROF8 but the word order is swapped when storing 
the number to the two consecutive DIT registers. 

RIS16 IN 16 Integer Inputs 16 contiguous single DIT registers as 16 integers 
RID16 IN 16 Integer Inputs 32 contiguous DIT registers as 16 double integers. 

i.e. Each integer is derived from a contiguous pair of 
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DIT’s as a single 32 bit integer 
RID16x IN 16 Integer As per RID16 but the word order is swapped to calculate 

the double integer. 
RIF16 IN 16 Float Inputs 32 contiguous DIT registers as 16 IEEE floating 

point numbers. i.e. Each floating point number is derived 
from a contiguous pair of DIT’s as a single 32 bit floating 
point number. 

RIF16x IN 16 Float As per RIF16 but the word order is swapped to calculate 
the 32 bit floating point value. 

ROS16 OUT 16 Integer Outputs 16 integers to a contiguous block of 16 single 
DIT registers. 

ROD16 OUT 16 Integer Outputs 16 integers to a contiguous block of 32 DIT 
registers – each integer occupying two consecutive 
registers as a 32 bit value. 

ROD16x OUT 16 Integer As per ROD16 but the word order is swapped when 
storing the double integer. 

ROF16 OUT 16 Float Outputs 16 IEEE floating point numbers to a contiguous 
block of 32 DIT registers – each number occupying two 
consecutive registers as a 32 bit number. 

ROF16x OUT 16 Float As per ROF16 but the word order is swapped when 
storing the number to the two consecutive DIT registers. 

Table 8-1 DIT based ISaGRAF Virtual I/O Module List 

 

8.8 Teleterm M2 RTU Specific Function Blocks 
In addition to the standard library of functions and function blocks available in the 
Application Workbench, some additional Function Blocks (such as Auto-tuning PID control 
blocks) are available for the Teleterm M2 RTU. 
Details of these function blocks can be found in the separate Function Block Application 
Notes distributed with these function blocks. See your Omniflex distributor for availability. 

 

8.9 Quick Start Example 
This example is a quick step by step instruction from starting IsaGRAF for the first time to 
getting a simple program running on an M2.  
 

1. Start IsaGRAF. 
2. From the menu select File -> New 
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3. Give your project a name… 

 
4. In the Programs window, from the menu select File -> New. 

 
5. Give the program a name and select FBD for the language. Then Click OK. 
6. Click Make -> Compiler Options. 
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7. Select ISA86M: TIC code for P3 & C236xC, then click OK. 

 
8. In the Programs window, double click on your program to open it. (test) 
9. In the FBD/LD Program window, from the menu select File -> Dictionary. 
10. Select the Booleans tab. 

 
11. Double click under the name space and add three Boolean variables as follows: 
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12. Then you should have this: 

 
Save and close this window. 

13. Make a Boolean AND function. 
Add Input 1 and Input 2 to the inputs and Output3 to the output. 
To add the inputs, you have to click on the “Insert Variable” (4th icon from the left on 
the bottom row.) button and look for the variables that you created in step 12. 

 
14. Save and Close the FBD/LD Program Window. 
15. Back in the Programs window from the menu select Project-> IO connection. 
16. Double click on slot 1 and choose m2di. 

Slot 2 – m2di. 
Slot 3 - m2do 

UMC236xCR045.pdf 90 -© Omniflex 
 



Teleterm M2 Series RTU User Manual  

 

 

 
 

 
17. Now Connect Slot 1 and Variable: Input_001 

Connect Slot2 and Variable: Input_002 
Connect Slot3 and Variable: Output_003 

 
18. Save and close this window.  
19. In the Programs window, from the menu select Make -> Make Application. 
20. Program will compile with no errors. 

 
21. Click EXIT. 
22. Select Debug->Link Setup. 
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23. Select Conet Server for ‘Communication Port’. 

 
Click Setup… 

24. Select Conet/s on the COM Port that you are using. 

 
25. Click On OK, and OK. 
26. Then click on Debug->Debug. 

 
27. If there’s any program running, then stop the program. 
28. Then Download TIC Code, by selecting File->Download from the menu. 
29. The program should start to run after download completes. 
30. If Input 1 and Input 2 are ON then Output 3 will come ON. 
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9. Maintenance 

9.1 Battery Type 
The Teleterm M2 is equipped with an internal clip-in battery for retaining the real time clock 
during power failures. 
This battery is a type CR1220 Lithium Battery. This battery is commonly available from 
electronic stores or can be obtained from Omniflex. 
It is recommended that the battery be replaced at least every three years, or when the 
battery low indicator in the Teleterm M2 shows LOW. (See the Real Time/Product Status 
Group in Omniset. 
 

9.2 Battery Replacement Procedure 
To replace the internal battery proceed as follows: 
1. Remove the top cover of the Teleterm M2 by undoing the two hex cover screws on the 

top of the unit. The cover is connected to the unit by the internal antenna cable, so be 
careful not to place any strain on this cable while removing the cover or inserting the 
SIM card. 

2. You will see the battery toward the left lower side of the unit. 
3. Unclip the old battery and replace with a new battery  
4. Replace the top cover. 
5. Restore power to the Teleterm M2. 
6. Using Omniset, check that the Battery Indicator is showing “Healthy”. 
7. Using Omniset, set the Current Date and Time of Real Time Clock: 

 
8. Take care in disposing of the old Lithium battery to preserve the environment, and to 

prevent accidents. 
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10. Technical Support 

Lifetime technical support for all Omniflex products is available by email on 
techsupport@omniflex.com.  
 
Alternatively, you can check the knowledgebase on the Omniflex web site at www.omniflex.com.  
 
 
 
 
 
 
 
 
 
 
 

COPYRIGHT AND PROTECTIVE NOTICES 
1. The Copyright of this document and the associated drawings, is the property of Omniflex and 

is issued on condition that it is not copied, reprinted or reproduced or transmitted in any form 
or by any means, electronically, photocopying, mechanical or otherwise, nor its contents 
disclosed, either wholly or in part, without the consent in writing of, or in accordance with the 
conditions of a contract with Omniflex. 

2. The publication of information in the document does not imply freedom from patent or other 
protective rights of Omniflex or others. 

3. Although every intention is made to ensure that performance figures and data are accurate the 
company reserves the right to alter without notice any product or specification.  Performance 
figures and data must therefore be specifically confirmed by the company before they become 
applicable to any tender, order or contract. 

4. In the case of electrical components, enough data is included in the drawings to allow 
maintenance of the equipment.  However, if component availability or substitution information 
is required please consult the factory for assistance, as it is impossible to include data on 
every component in this document. 

5. This product is sold without liability for consequential loss of any description. 
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